Sync fails

I use the sync server and paid storage server. I sync between Linux w/ FF 3.6 and ext4 and Windows 7 w/ FF4 both with v2.1.8 of the plugin. Syncing of citations and files seems to be working; however, the linux system is giving me an error with every sync:
"The file 'Z5I26V73/bt+xjmx+pteymzq+nzq3nte2mjemchq9mtizndq3ndc1ndy5nizwptm3mzu4mszkpunorvqlnuzsqiu1rkzjtkrfuiznptqmdd+mbz+yyzm1mguxymnimgu+owm1yjzinwq3nza5nmzmogvizizzpwnuzxquy29t.gif' could not be created in the Zotero 'storage' directory."

I reported this as error #: 842840343

I looked in path/to/storage/Z5I26V73 and worked out the reference and then used the plugin interface to try and remove and re-attach the snapshot but I'm still getting the same error.

$ touch path/to/storage/Z5I26V73/bt+xjmx+pteymzq+nzq3nte2mjemchq9mtizndq3ndc1ndy5nizwptm3mzu4mszkpunorvqlnuzsqiu1rkzjtkrfuiznptqmdd+mbz+yyzm1mguxymnimgu+owm1yjzinwq3nza5nmzmogvizizzpwnuzxquy29t.gif

gives me "Cannot touch ... File name too long"

Short of switching to a file system that supports longer file names how can I clear this error?
  • try to find a way to shorten the filename - maybe just delete the file?
    Also, where are you getting that snapshot from?
  • The file isn't there to be deleted. Zotero can't create it.

    The attachment is a snapshot of:

    I'm not sure where the file names are created but that file name does not appear in the source of the article.
  • It's an advertising request made via JavaScript, which is getting converted into a file by Zotero's snapshot saving mechanism.

    We'll be adding better handling of this in Zotero 2.1.9, but that file should exist on your Windows computer. Delete it there and update the timestamp of the main HTML file (by, say, opening it in a text editor, making a small whitespace change, and resaving) to trigger resyncing of those files. Then the server version won't have that long file and you shouldn't get the error on Linux.
  • Fixed.
    Thanks Dan.
This discussion has been closed.