RIS Import: Wrong creator types

I have authors entered in the author fields for these citation types:

Bill, Map, Artwork, Hearing, Interview, Computer Program

...however no author comes over to the middle pane in the creator field and thus they sort to the very bottom of the list/pane. I imported these (plus many more types that worked just fine) from an RIS file.

Are these citation types legit? What field needs to be populated to get something in the creator field?

Thanks in advance.
  • ... was also going to note my version if that matters:

    Zotero version 2.1.8
  • I didnt' test all of those, but how did you enter an "Author" for Map or Computer Program?
    A Map has "Cartographer" - which shows up in the author column - and a Computer Program has "Programmer" (which also shows up in the creator column) - I assume the other items have similar name fields - at least those two don't have an author field. "Contributor" never shows up - neither in the middle column nor in citations..
  • Aha! The one thing I didn't do was to click on the "Author" heading and see that there are other designations, such as "Cartographer". As soon as I flip them from "Author" (how they were imported), they immediately show up in the Creator field. It looks like even though they were imported as "Author," this would not be an option if entering manually - and thus probably the reason for the disconnect.

    Thank you! And sorry for the silly question.
  • oh that's not a silly question then - how did you import them? That should have never happened (i.e. there never should have been an author for those types) and we would probably want to fix the translator you used.
  • I imported from RIS, which was an export from Reference Manager. Here are two entries that imported incorrectly:

    TY - MAP
    ID - 3537
    T1 - Ecoregions of New York (color poster with map, descriptive text, summary tables, and photographs)
    A1 - Bryce,S.A.
    A1 - Griffith,G.E.
    A1 - Omernik,J.M.
    A1 - Edinger,G.J.
    A1 - Indrick,S.
    A1 - Vargas,O.
    A1 - Carlson,D.
    Y1 - 2010///
    N1 - map scale 1:1,250,000
    KW - ecoregions
    KW - New York
    N1 - in file
    CY - Reston, Virginia
    PB - U.S. Geological Survey
    ER -

    TY - COMP
    ID - 1578
    T1 - Vegan: community ecology package.
    A1 - Oksanen,Jari
    A1 - Blanchet,F.Guillaume
    A1 - Kindt,Roeland
    A1 - Legendre,Pierre
    A1 - O'Hara,Bob
    A1 - Simpson,Gavin L.
    A1 - Solymos,Peter
    A1 - Stevens,M.Henry H.
    A1 - Wagner,Helene
    Y1 - 2010///
    N1 - R statistics, R package
    KW - Communities
    KW - ecology
    N1 - not in file
    IS - R package version 1.17-4.
    PB - http://CRAN.R-project.org/package=vegan
    UR - http://cran.r-project.org/
    UR - http://vegan.r-forge.r-project.org/
    ER -
  • OK, thanks - I don't think that should happen - these are primary authors and A1 is the correct label (Zotero exports them as A2, which seems questionable to me) - let's see if someone can fix that in the RIS translator -
    could you maybe change the title of this thread to something like
    "RIS Import: Wrong creator types"
    so it attracts the right people? (I think you can do that by editing the first post).
  • OK, done.
    Thanks again for everything!
  • Yes, I think you're probably correct that cartographer should be exported as A1 for maps, and A1 for maps should be imported as cartographer. I'll make the appropriate changes.
  • Please go to http://github.com/ajlyon/zotero-bits/raw/master/RIS.js and save the file to the translators directory of your Zotero data directory (http://www.zotero.org/support/zotero_data).

    It should start working again. If this works for you, please post here so that I can submit this change to be pushed to all users.
  • There may be other types with the same problem-- recordings, films, etc.
  • Your new translator worked for Map/cartographer, but, as you note above, I had other data types as well. I tried a Computer Program import (the example above) and that record came over with A1 tagged to "Author" not "Programmer". I know that Interview, Bill, Map, and Artwork have the same problems. I don't know about any others...
  • ajlyon - it would make sense to try to fix this globally - all primary author types - i.e. anything that ends in the creator column in Zotero - should probably go into A1 and be imported as such - probably a lot of work, though? Do we have to map this for each item type with a non-standard primary author type individually?
  • We could do that-- but we don't have a nice list of creator types anywhere, and we'd have to do this by specifying all of the cases (unless Dan/Simon want to add a function to magically assign the primary creator type for a given type).
  • right, that's what I feared - but one of the two should happen - the fact that Zotero can import de-facto invalid references (might even cause problem syncing?) and exports wrongly is not good.
    I'd prefer a more generic solution - maybe Dan or Simon could say if that's sufficiently easy so that it could happen in the near future. If not I fear we'll have to go the hard way - I can probably help you make the list - shouldn't take too long using Franks mappings.
  • As soon as I flip them from "Author" (how they were imported), they immediately show up in the Creator field. It looks like even though they were imported as "Author," this would not be an option if entering manually
    That definitely shouldn't happen. We'll look into it.
  • edited August 4, 2011
    Fixed on the trunk (for the next major version of Zotero). Creator types that don't exist for an item type will be automatically converted to the item type's primary creator type.
Sign In or Register to comment.