MacWord integration not working after Firefox 5 upgrade

Hi there,

I was running the firefox 5beta (stable release) on my MacBookPro with latest Mac OS and Word for Mac 2011 - all fine and dandy.

The Firefox 5 update in the last day or so has killed the MacWord Integration. Firefox tries to update and integrate with word, tells me it can't via an error message - which usually tells me to close word (word is not open).

Any ideas?
  • edited June 22, 2011
    Mine just stopped working (at least partially). I'm now using FF 5.0 and the same setup as anthony. Just tried to refresh the document where i was working and this error appears:

    However, I seem to be able to add a citation. It takes 1 min and 20 seconds just to show my library... it used to take 30 seconds with FF4... and i was getting used to it...
    I have a 170 pages document with about.. 50 references until now.. not a lot. Can't understand how it takes so long...

    UPDATE: I changed the citation style of my document, then changed it again back to the original, then refresh and it works again. It takes around 30-40 seconds to add a citation.. but at least it's working
  • this looks related:
    (no solution there either, just flagging the issue).
  • edited June 22, 2011
    Anthony J. Langlois, generate a report ID.

    tester123, this sounds unrelated. If you can reproduce it, generate a report ID as well. We can't do anything about citation insertion speeds in Word for Mac. They are limited by the way we communicate with Word, along with Microsoft's refusal to give us access to faster methods.

    adamsmith, I don't think that's related. The installation process is entirely different between Mac and Windows. The only similarity is that (presumably) something about people's systems changed between initial installation and upgrade (because nothing about the installation code has changed since 3.1 or earlier), and this causes an error dialog to appear on upgrade...
  • Here is an error report ID: 620311657

    Here are the errors on the error console after following the steps on following start up errors:

    Error: gBrowser.addProgressListener was called with a second argument, which is not supported. See bug 608628.
    Source File: chrome://browser/content/tabbrowser.xml
    Line: 1840

    Error: no element found
    Source File: moz-nullprincipal:{b0b8cdf7-f7c4-e74f-823b-05b482d3ab9a}
    Line: 1

    Error: no element found
    Source File: moz-nullprincipal:{b0b8cdf7-f7c4-e74f-823b-05b482d3ab9a}
    Line: 1

    Error: uncaught exception: Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]
  • Anthony J. Langlois, try uninstalling Zotero MacWord Integration and PythonExt and reinstalling them from the installation page. If that doesn't work, try starting Firefox from the command line and check whether an error message is visible.
  • Many thanks Simon, that seems to have fixed it (the uninstall/reinstall).

    Keep up the good work! We all LOVE Zotero!
Sign In or Register to comment.