cannot drag and drop items into collections when any pdf is open...

I have developed a strange problem in zotero, that i think started with the last update.

Basically, i cannot drag and drop an item into a collection folder when i have a pdf open in the browser. Although i can pick up the item, the folders do not 'turn blue' when i hover over them and the item does not appear in the folder when i drop it.

As soon as close all open pdf's, then the functionality returns and i can drop the items into the folders. Very annoying when i've got several pdf's open!
Anyone have any idea why this might be?

oh, and i'm using zotero 2.1.8 in firefox 4, running in the Kubuntu variant of linux mint (kde). the issue occurs when zotero is a tab and in the browser pane style.
  • anyone else with this problem?
  • 18 months later and this is still an issue.
    Is there a work-around/fix or am i missing something?
    (now using zot 3.0.11, kubuntu 12.10, firefox 18)
  • Can you restart Firefox, trigger this, and then provide a Report ID?
  • hi,
    Report ID: 830229805

    Thanks for you interest!
  • I occurred to me that i may not have actually tried to 'drop' the items prior to producing the error log, so just in case, i did it again...
    Report ID: 22563879
  • No Zotero errors in there, but have you tried disabling your other extensions? (Specifically, Ubuntu Firefox Modifications has caused problems in the past.)
  • If that doesn't work, a Debug ID for the drag attempt may be helpful.
  • i'll give it a go and report back....
  • i'm afraid disabling all addons (apart from zotero, obviously!) made no difference.
    will try the debug and report back.
  • ok, followed the instructions, and the Debug ID is D1468925054.
    thanks again.
  • Is this actually when you have any PDFs open, or just when you have a PDF open in the current tab (in pane mode)?

    If the former, I don't really have any idea what would cause this, but it'd be helpful to see two Debug IDs: one with a PDF open and another without. Both should be generated with all other extensions disabled.
  • It seems to occur when i have any tab open.
    Using firefox i 'group' my tabs (for particular projects/areas of interest etc.), and this pdf drop issue occurs if a pdf is open in any group, even if not currently onscreen/in the group of open tabs.

    will do the two debugs later this evening, when i've a bit more time.
Sign In or Register to comment.