renaming does not work with zotero option or zotfile

[NOTE problem has been solved: seems to have been something wrong within Firefox. A new FF+zotero installation works fine - can't seem to delete this thread though]


I have a problem with the pdf renaming function. Windows 7, Firefox 4.01, Zotero 2.1.6.
When I rename a pdf, it seems to rename the file in the folder (which I check by locating the folder before the renaming). However, the reference to the file is not changed within zotero, meaning it is shown as the old name in the tree view and in the info pane. As a consequence, zotero cannot locate the file after the renaming. I have tried restarting and reindexing, doesn't help. I read about a similar problem for earlier versions, but only found that the issue is supposed to have been resolved..
At the same time (maybe related??), when I use the zotfile plugin, it does rename the file in the source folder, and shows a correctly named pdf in the tree view. However, the info pane shows the original filename (!). As a consequence, the tree view doesn't show a pdf icon, but a broken link icon (logically, as zotero is obviously using the filename shown in the info pane to locate the file, but the file has been renamed). Strangely now, if I repeat the zotfile import, THEN I have 2 broken links and 1 correctly working link to a folder within my zotero database (i.e., a subfolder containing the pdf).
In contrast, trying the zotero-built-in rename several times in a row doesn't have any effect.
I'd be thankful for help.
Sign In or Register to comment.