LibreOffice does not recognize refs in doc-files


when using LibreOffice, I can add and change references as in Openoffice. However, when I edit doc-files, all links are broken upon reopening the file in LibreOffice.

Also in previously edited doc-files (using OOo), no references are recognized.

LibreOffice 3.3.2
OS: Xubuntu 11.04
FF: 4.0.1
Zotero: 2.1.6
Zotero OOo Int: 3.5a2r8874

Best, dnh
  • as per the description displayed when you create a new document (or when you change the document settings) Reference Marks - the standard setting for Ooo and LO - are not saved in .doc files. This is true for Ooo and LO equally. Use Bookmarks instead.
  • Adam, this is what I did, of course. I have been using Zotero for three years now.
  • So these all work when you edit them in LibreOffice only, and break when moving between Open and Libre?
  • Sorry, my description was imprecise. It boils down to this: Whenever I open a doc-file (with bookmarks) in LO, they're all broken. It does not matter whether the file was edited in LO or in OOo before opening in LO.
  • Same here with Ubuntu 11.04 and the same setup. Editing with .odt-files works, but .doc-files doesn't.
  • Would anyone know if this problem is being solved? I'd love to migrate to Ubuntu 11.04, but I am hesitant to do so until this problem is fixed.
  • I don't think this is being worked on with high pressure, no. I do think it should and will be fixed eventually, but I don't think it's going to happen soon. But couldn't you just install Ooo on the Narwhal?
  • I just tried LO 3.4 on W7, still doesn't work properly ... I am sort of getting frustrated. It is not possible to install the integration in OO 3.3 due to the "implementation loader" problem (see other thread) and on LO 3.4 it doesn't work with doc-files ... I don't feel like leaving Zotero, but I need a program that works and not kills an entire working day without any result ...
  • Can you be more specific about what "doesn't work properly" means? Bookmarks should work with LibreOffice in OpenOffice Integration 3.5a2, and they do on my test system.
  • Hi, my comment from May 2 still applies: "Whenever I open a doc-file (with bookmarks) in LO, they're all broken. It does not matter whether the file was edited in LO or in OOo before opening in LO."
  • HI Simon, just to confirm on ubuntu 11.04 libreoffice 3.3.2 zotero 2.1.8 and 3.5a2
    Create a dummy document, insert a reference using bookmarks as the option, save it as test.doc
    close the document, open it up and the zotero link is gone, can't edit or refresh. What is your test system setup?
  • Ah, I was expecting the problem to be what it had been before (that Zotero threw an error trying to read bookmarks). Now it looks like the problem is that LibreOffice no longer preserves document properties when saving in doc format. I'll file a bug report.
  • dnh
    edited July 5, 2011
    Thanks, Simon. Let's hope it gets fixed in the near future. Would also be great, if a solution for the implementation loader problem could be found (
  • The bug has been reported previously quite a while ago (I've added a link to the original bug report). But it doesn't seem that anyone at LO is too concerned. Maybe others experiencing the same problem could confirm the bug and stress that it is important that it will be fixed - the site is .
  • This appears to be fixed in LibreOffice 3.4.2rc2.
  • I'm running LibreOffice 3.4.2rc3 on Ubuntu 11.04 and it does indeed seem to be working now
  • LibreOffice 3.4.2 final is now out which fixes the problem here.
  • I just tested it using LO 3.4.2 on W7 - it works. I will test it on Kubuntu 11.04 tomorrow. Zotero-folks, thank you for your help. And goodbye to OpenOffice.
Sign In or Register to comment.