Translator error on PNAS (Highwire 2.0)

  • Please go to 2.0.js and save the file to the translators directory of your Zotero data directory (

    It should start working again. If this works for you, please post here so that I can submit this change to be pushed to all users.
  • I confirm that the article can be saved now. (Browser restart was needed after updating the translator.) However, I did get an error on the first attempt to save. It worked on subsequent attempts.
  • You shouldn't have needed to restart Firefox, but you would need to reload the page.

    I also got intermittent errors in testing, but I think they had to with how I canceled the PDF download that the embedded PDF kept triggering, and there's not much we can do to prevent that.
  • After I reloaded the page, it didn't use Highwire 2.0. It said: "Embedded RDF" or something similar. That worked but didn't give me the PDF.
  • That's essentially the intermittent issue I'm still seeing, but there's about nothing we can do about it. Does the translator give you the PDF now?
  • Sure, the Highwire translator does. The embedded RDF thingie before restart didn't
Sign In or Register to comment.