Error while importing pubmed or pubget references

Since yesterday I get error message

(Zotero pops up a message:
"Could Not Save Item.
An error occurred while saving this item.
Please try again. If this error persists,
contact the translator author.")

when importing references from pubmed or pubget. Import from amazon works fine.
My translators are up to date.

Firefox 4.01
Zotero 2.16

Thank you for help!
  • works for me.

    Does the magic wand (Add Item by Identifier) work using a PMID?
  • Your reference worked also fine for me.
    But doesn't work but it does with the magic wand!

    What could be the reason?
  • Works for me. Can you provide an error report ID for this error?
  • When trying it now again it worked now also for me. I don't know what was the prob yesterday and today morning......
  • I am also having trouble with the PubMed translator. Specifically, when I try to save a publication from pubmed, found by single match search, to a Zotero collection it does not work.

    Here's a link where it does not work:

    If I click on the same publication from a list, and then save the publication to Zotero, it does work as with this link:

    I can also import the publication using the wand tool.

    Report ID# 777387577 and using Zotero 2.1.6 and Firefox 4.0 on Windows 7.

    Thanks much!
  • i'm having the same problems importing references via the single citation index in pub med. sometimes it works, zometimes not. what could be the problem. I've taken all actions in the troubleshooting category.[page]+AND+1995[pdat]+AND+Morton[author]&cmd=detailssearch

    doesnpot work.
    greetings jo
  • Thanks for nailing down a page that doesn't work.

    Please go to PubMed.js and save the file to the translators directory of your Zotero data directory (

    It should start working again. If this works for you, please post here so that I can submit this change to be pushed to all users.
  • Thanks so much ajlyon!

    Works perfectly now. I tested it with a couple of different pages that I had trouble with earlier.
  • Fix committed. Should be in the next version of Zotero.
  • Great thanks!

    Will the change be pushed as an updated translator? Or, will appear when Zotero 2.1.7 becomes available? I have a few colleagues who will need this update as well and I'm trying to decide what is the most efficient way for them to get it.

    Thanks again.
  • I hope it will be pushed, but I don't know if Dan will. Otherwise, it will appear when Zotero 2.1.7 comes out. In the meantime, your colleagues can install from the Github link above.
  • Good to know. Thanks again.
  • edited April 25, 2011
    Pushed. Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.
  • Excellent, thanks very much for the update, Dan.

    I'll let my colleagues know.
  • I'm still having this problem with Pubget (I updated to the latest version).

    A URL to try is:

    And a Report ID for the failure is: 1807962

    I'm getting the Could Not Save Item dialog box described above.

    If it is something that changed on our site, please let me know. I took a look at the translator and the line reporting the error, but didn't understand how to make it right.

    Mike (Pubget)
Sign In or Register to comment.