Zotero Standalone crashing with OpenOffice.org (Ubuntu 10.10)


I'm now very advanced on my doctorate proposal and now Zotero is crashing. I'm using the latest standalone versions plug-ins for Firefox (3.6.16) and OpenOffice.org (3.2.1).

Almost every time I make a citation I have to re-start Firefox with Zotero installed. This is the process that I'm doing to keep working with the bug (very slowly):

1) I first refresh Zotero on OpenOffice.org, to secure if it is working fine . If There's a warning telling that Zotero is not working I refresh again (some warnings says "Zotero experienced an error updating your document. Citations is undefined"). If there's no warning and the refreshing acts as normally then I proceed with a citation.

2) If not, if there's no warning but firefox is crashed (there's no appear of the "{Citation}" block on OpenOffice.org), then I have to re-start Zotero (this is the most frequent alternative) going to the terminal and "ps -A" and then "kill #" of the process. Then proceed with step 1.

3) If the refresh acts normally, I try to put a second citation. I do what I said on step 1. If everything is fine I proceed with an improbable third citation.

The most frequent alternative is the step 2 in all the job. So you can image the hard and slow work.

I reported the error. The report number is: 1347127472.
  • You're running Zotero OpenOffice Integration 3.1b1. Try 3.5a1.
  • Thanks Simon, I tried that version but it didn't work. It never respond to the Zotero local database. Maybe is because that version do not work on standalone contexts. What I need is a standalone version.
  • Hello:

    I'm just posting to let you people know that the big problem reported here is solved on the alpha version of the Standalone version of Zotero (without Firefox).

    Is curious to see that the alpha version looks more stable than the normal version of the Standalone.
Sign In or Register to comment.