'rename file from parent metadata' fails silently - Zotero 2.1.1

The menu operation 'rename file from parent metadata' fails silently. I am running Firefox 4.0 on Windows 7 Ultimate.

Typical Scenario:

retrieve metadata for pdf, then 'rename to match parent metadata'. Retrieval of metadata seems hesitant - have had to try twice sometimes. 'rename to match parent metadata' does nothing.

Behavior has change since uppgrading browser to 4.0 and Zotero to 2.1.1

--Peter G
  • Hi Dan,

    The 'Report Errors' menu is grayed out. I tried to rename using metadata twice on different PDFs after your response - I had restarted the system, and not used Zotero since the restart, the first time I tried - the renaming happened immediately, the second time - nothing happened.

    --Peter Goodall
  • And when you right-click "show file" on one of these - are they still accessible from Zotero? Has their file-name really not changed?
  • edited April 4, 2011
    [ignore post please]
  • I'm confused - at what point does "rename file from parent metadata" fail?
  • After I click the menu on the file - it 'intermittently' does not rename in the UI. I am just working on reproducing this and checking if the file-system rename has happened. having trouble retrieving metadata for ACM PDfs which is complicating things....
  • use the doi to get the article - you're endnote method is way too complex.
  • Sorry - that 'endnote method' was not meant to post. Was trying to get metadata by any means - given retrieval for ACM papers seems to be failing for me. Definitely not my normal process. Getting PDFs and metadata from citeseer right now.
  • After a number of retries I cannot reproduce this other than intermittently.

    Followed this process:
    Added item to Zotero using DOI 10.1145/1597735.1597737
    Double click to open item - opens page at ACM.
    Drag PDF full-text link/icon from screen onto zotero item created from DOI
    ft_gateway.pdf added to item.
    "Show File" menu item shows file named "[...]\zotero\storage\54TIEQCR\ft_gateway.pdf"
    "Rename File From Parent Metadata" menu initiated

    --Failed to rename file once (and in directory), and then worked subsequently, for three retries (removed file and metadata from library between tries).

    I suspect it may be a timing issue with asking for the rename while something in Zotero is still settling during ingest of the PDF.

    ---Peter G
  • ah yes - I'm pretty sure that's it - if you do it too quickly after getting the pdf I believe that's the issue.
Sign In or Register to comment.