Tab mode: panes not populating correctly

Everything is fine in "regular" mode, but when I toggle to tab mode, the left and middle panes do not populate correctly. They are essentially blank, or have some random entries. They populate and depopulate as I move the cursor up and down. If I move the cursor to another pane, the previous pane depopulates completely.

Toggle back to "regular" mode...everything is fine again. Toggle back to tab and the same problem.

Really, I don't do drugs.

FF 4.0
extensions disabled
Z 2.1.1

The Debug ID is D423202690

Edit: No error report triggered
  • can you screenshot that in an illustrative way?
  • Maybe a related issue--Zotero remembers different saved search folders in tab and non-tab mode. For example, I work in folder A in non-tab, then switch to tab and move to folder B. Then I switch to non-tab: I'm back in folder A; work some more, switch to folder C. Then I switch back to tab: I'm back in folder B.
  • I started a similar discussion, but no response. So, I'll second this one. Sometimes, I even get a duplicated source showing in a collection that is supposed to have only one source. Then when toggling the duplicated source disappears. I'll try taking some screen shots as well.
  • Here are some screen shots. All I did was move the cursor around. No clicking involved. Too bad I can record the video of it. It's pretty strange.

    @erazlogo: I'm not working with a saved search. Just My Library
  • that looks wild - maybe your computer is on drugs...
  • LOL! I'll see if I can get it to pee in a cup.
  • I got some screen shots for Report ID: 1879432233. They can be seen at:

  • edited March 24, 2011
    arggem: Try disabling your other Firefox extensions. That doesn't look like us.

    Elena: We'll look into that.

    SteveM: Still thinking about your issue, but we'll respond on your thread, not this one, which isn't really related.
  • arggem says he did that... there's nothing else visible on the screenshot either.
  • arggem, try disabling hardware acceleration in Firefox and see if this still happens.
  • Simon, It still happens even with hardware acceleration disabled.
  • It may not be necessary, but did you restart Firefox after changing the hardware acceleration setting?
  • Dan, yes, I restarted Firefox after disabling hardware acceleration.
  • FYI: Z 2.1.2...The problem is still here.
  • I'm experiencing this as well, in 2.1.5 under Firefox 4, in Tab mode. The editing pane and tree entries blink on and off like Christmas lights as the cursor hovers nearby.
  • Update: I believe this is a zooming phenomenon. It's possible to zoom in the editing pane (Ctrl-Mousewheel) to where tree elements disappear; they'll reappear intermittently under the cursor.

    At the default font size, the tree appears intact. So the issue is avoidable. Still, a graceful zoom is a good thing. I was zooming under a window splitting extension, Tile Tabs, to get the narrowest editing window that would not cut off text. Just seemed a little easier than manually sizing the Zotero panes.
  • Wow, nice catch JJS!

    Same here. A little experimenting with ctrl + and ctrl - yielded some bizarre results

    Display was normal for -3 -5 Default, +1 +2 +3 +6 +8

    abnormal for -1 -2 -4 +4 +5 +7

    Seems consistent.

    note: +/- x means the +/- key was pressed x times from default
Sign In or Register to comment.