Error: "Could not create Java implementation loader"

  • Everything is working fine for me on my dev machine with Java 7 Update 5, so this is probably not a general issue. However, I don't have any unique insight into troubleshooting Java issues on Windows.
  • LibreOffice bug 50371 describes configuration issues with Java 1.7. Comment 15 has a detailed set of steps that may help.
  • I had the same problems as mentioned above and tried multiple versions and reinstalls of every thing. I got it working by using the latest versions of java and zotero and the new beta version of libre office, pre release 3.6.0 beta 3. It was using the beta version of libre office that was key to getting it working. I hope you find the same works for you.
  • Windfire, I had the same issue and tried your voodoo fix and it worked for me. Thanks a lot.
  • Here's another piece of voodoo which worked in Windows Vista. Open Office 3.4.1. Go to the Java control panel, check the button in "Advanced" which says Allow using insecure Java versions. Open Open Office, under Options - Java uncheck version 1.7 and check Close Open Office, (and the quickstarter) , and press the reinstall button for the extension in Zotero preferences - Cite.

    This also fixed the problem for Oracle Report Builder.
  • sjgold: As the Java control panel indicates, Java 1.6.0_25 is insecure. Navigating to the wrong website while Java 1.6.0_25 is enabled could allow a virus to infect your computer, or allow an attacker to access your personal data.

    The instructions on the troubleshooting page should solve this issue with Java 1.7+. However, if that doesn't work, you should install Java 1.6.0_35, which has the latest security patches.
  • If you have this problem and none of the solutions work, please have a look here (esp. under "How to continue now") and contact us at LanguageTool - our extension has the same problem sometimes and we'd like to have it finally solved:
  • pyrosopher's solution worked for me. It wasn't clear to me that the Java selection under Tools/Options/Advanced actually had to be checked. Once I did that it reinstalled fine. I'm missing the icons, but I don't care and don't want to mess with it because it's working. Thanks for your help!
  • Error Report Id 567948348
    When I try to install the Open Office extension it says "Could not create Java implementation loader"
    So basically I have the same problem as you but I'm not really an expert in computers nor in English so I try to understand what you all say but I'm having a really hard time with all this stuff... I think I have done properly everything written on this forum from the uninstalling everything to the re-installing everything (including both 32 and 64 bit java) and nothing works, I don't even have a zotero tool bar. So I tried the Debug thing and they ask to post the problem on a forum otherwise they won't fix it so that's what I'm doing now... If anyone can help me :) thanks
  • which OpenOffice version is that and which Operating System?
  • I'm running Windows 7 with Open Office 3.3 and Firefox 23.0.1 with the latest version of Zotero
  • edited September 27, 2013
    I think that OpenOffice 3.3 only works with Java 1.6, which you shouldn't use because it's outdated and insecure. You should either update to LibreOffice 4.1 or Apache OpenOffice 4; I recommend the former.
  • All right so I downloaded LibreOffice 4.1 and I tried to make zotero work in there but I get exactly the same message.
    In the extension manager it says "Error:Status of extension unknown" and when I click "Activate" it says "Could not create Java implementation loader"... I've tried to download Zotero not from the Zotero platform but from the LibreOffice Extensions website and... zotero doesn't even exist in there ! How come ??
  • I uninstalled libreoffice integration plugin in firefox and re-installed it and now it doesn't even appear in libreoffice's extension manager... this is definitely not getting better...
  • It's getting worse and worse now I have another error ID 583680914 because when I go into Firefox Extensions, then in the LibreOffice Integration I click on "Options" and it says the add-on is not properly installed, it asks me do I want to install it now and I say "Yes"... but then it says "An error occurred and LibreOffice integration could not be installed". Help please!
  • Open the LibreOffice/OpenOffice options dialog by choosing Tools→Options. In the dialog, click LibreOffice→Advanced. Ensure that “Use a Java runtime environment” is checked, and that a JRE is selected in the list below. If there is a JRE in the list but it is not selected, press the button to the left of it.
  • It's working now ! Thank you very much Simon. I really wouldn't have figured this out all by myself !
  • Ok Hi all new user to Zotero.
    I found trying to use it with libra office I had the same message.
    After reading this thread I found my own solution to be this.

    Firstly I had the 64bit version of Java installed and Libra office 4.3 was 32bit or x86. So to fix this I installed the Java Runtime Enviroment x86. Then went to the Tools ->Options ->LibreOffice ->Advanced and leaving the Java options use a java runtime environment I noticed there was two Oracle Corporation 1.8.0_25 option plus an older version, one is the x86 option and the other is x64. By checking and studying the path it is possible to deduce which is the correct version to run. Simply check the version with program file(x86)in the path, then go back and install the plugin. All working without an issue.

    Cheers all future readers of this post.... :)
Sign In or Register to comment.