Error: "Could not create Java implementation loader"

As the topic says. As soon as I try to install the actual extension, I'm presented with said error message: "Could not create Java implementation loader". The Zotero toolbar does appear in Writer but its buttons don't do a thing.

I use: Windows 7 32-bit, 3.3.0, Firefox 3.6.15, Zotero 2.1.1, Zotero extension 3.5a1.
  • I forgot: Sun/Oracle Java 1.6.0_24-b07.
  • edited March 21, 2011
    This is an issue. There are some reports at the forum that you can fix this by uninstalling, restarting, and then reinstalling.

    You could also try unchecking "Use a Java runtime environment" in Tools->Options->>Java, restarting your computer (restarting is sufficient, although you will have to quit Quickstarter unless you disabled it manually), opening again, re-checking the box, and restarting it again.

    You may have to enable/disable or reinstall the Zotero extension after completing these steps. Let us know if this works.
  • I should've written that I already had tried out everything you've suggested before posting here. I also tried deleting the OpenOffice preferences folder. I removed OpenOffice and Java, then installed the version that comes with the JRE integrated. Alas, nothing worked.
  • edited March 21, 2011
    Would you mind trying to install another Java-based extension (e.g. Oracle Report Builder) and seeing if you get the same error? If so, you're probably best off posting on the OOo Forum or the Community Forum, where people more knowledgeable with the intricacies of OOo Java might be able to help you. You could also try installing LibreOffice instead of, although I can't guarantee that this will work any better. The plug-in works fine on our Windows 7 test systems with both and LibreOffice, so it should certainly be possible to make it work.
  • D-G
    edited March 22, 2011
    Oracle Report Builder doesn't work either. I don't think that posting on said forums will do me any good because I already scoured both of them for every bit of information. There are apparently no "solutions" other than the ones you've suggested and which I already tried excessively. For some people on these forums claim it worked, for some it didn't. I belong to the latter.

    OpenOffice's fault or not: the only thing I know is that the Zotero OpenOffice extension 3.1b1 I can install without any error messages. (Alas, I can't use it. As soon as I want to cite something in Writer, a source code window with an error message pops up.) So I'd guess that something must have changed with regards to the Zotero OpenOffice extension 3.5a1.
  • oh yes - 3.5 changed the Java implementation completely -
    the old one was a constant source of trouble - (not to install, but lots of people had problems getting it to work - as I'm sure you have noticed looking through old forum threads).
    But there is really nothing else we can do for you here - something is clearly wrong with your Ooo and we can't fix that here. I guess I'd try Libre Office if you haven't already, but that's pretty much it then.
  • D-G
    edited March 22, 2011
    So, I got it to work (both Oracle Report Builder and Zotero):

    1. I installed both extensions which, of course, failed. But then I just let them sit there in their half-installed state instead of removing them.
    2. I disabled Java in OpenOffice.
    3. I uninstalled Openoffice.
    4. I rebooted my computer.
    5. I reinstalled OpenOffice.

    When I now started Writer anew, it picked up both extensions.

    It'd be nice to say "Done!" but, alas, I can't. Because even though Zotero is now installed in OpenOffice, I can't use it. The toolbar is there, but when I click on a button -- any button -- nothing happens. No, I can't create a Report ID as "Report Errors" is greyed out in Zotero.

    I have not the faintest idea what's gone wrong now. (And no, it doesn't work with LibreOffice either.)
  • Try re-installing the Zotero extension in OOo again and restart your computer. If that still doesn't work, generate a debug ID for what happens when you click the "Add Citation" button.
  • Do you by any chance have a 64 bit version of Open Office installed, but only a 32 bit Java Virtual Machine? I had the same problem until I installed a 64 bit JVM.
  • It's a Mac issue too. Same error msg (Could not create Java implementation loader) when trying to manually install the OOo integration extension into Open Office. I've followed the above instructions and still end up with the same error.

    Running Mac 10.6.6, Firefox4, OO 3.2.1, Zotero 2.1.1
  • ploebs, try updating to 3.3 (or installing LibreOffice).
  • Success! OpenOffice 3.3 did the trick. Thanks much!
  • To round this out: it works now. As advised I activated the "Debug Output Logging". I then wanted to insert a citation, fully expecting it to fail. But -- lo and behold! -- it suddenly worked. I still have no idea as to why it worked as the system wasn't modified in any way between the time it didn't work and the time it worked. No reboot. No restarting Firefox. No restarting OpenOffice Writer. No nothing.

    Ah, well. Technology is so much fun.
  • I have the same problem as D-G (buttons that do nothing) on two of three systems. All systems have LibreOffice 3.3 and Firefox 4.

    * Fails: Windows 7 64bit pc (tried all restarts, uninstallations, installing older versions of ff and LO, even OOo and JVM. Zotero OOo integration worked fine before I upgraded to FF4, maybe LO3.2?)
    * Fails: Windows 7 32bit laptop (didn't try anything beyond reinstalls)
    * Works: Ubuntu 10.10

    I'm happy to collect debug info if someone knows how to generate that when the buttons don't cause an error - they just don't work.
  • edited April 27, 2011
    windows xp sp3 32bit RTM
    Firefox 4.0 final
    OpenOffice.Org 3.3.0 final
    Java Runtime Environment (JRE) 6.0 Update 25
    Zotero 2.1.6 XPI installed and enabled
    Zotero OpenOffice Plugin 3.5a1 XPI installed and enabled
    But Zotero_OpenOffice_Integration.oxt is installed manually later
    Start OOO, "Use a Java runtime environment" in tools->Options->>Java is checked , try to install Zotero_OpenOffice_Integration.oxt manually, then theres is a message "Could not create Java implementation loader", click OK and close the OOO, then resatart the OOO and uncheck "Use a Java runtime environment" in tools->Options->>Java, close OOO, restart it again and check "Use a Java runtime environment" in tools->Options->>Java , restart OOO again. This time when I try to install the Zotero_OpenOffice_Integration.oxt, it will be installed correctly with no error.

    It workes for me. : )
  • I have now installed LibreOffice 3.4 beta3 (remember it's still a beta) on my Windows 7 / 64bit machine. Although the buttons only have text and not the pretty icons - it does all work again.

    (Also works fine with the defaults applications in Ubuntu 11.04, so now I just have to check the 32bit Windows 7 laptop)
  • dnh
    edited July 5, 2011
    I have the same problem using FF5 and OO3.3.0 on W7 with Java 6.0 Update 26. I've tried countless suggested solutions for hours now, to no avail. It does not work, I always end up with the implementation loader problem.
  • edited July 5, 2011
    I have never successfully reproduced the implementation loader problem, so I can't file a bug report. You should try the OOo Forum or mailing list first. You could also file a bug report with OOo, but I doubt anyone will put effort into this unless someone can provide reliable steps to reproduce with a new installation.
  • Thanks for reply, I tried both places - and I tried every possible suggestion to solve the problem I could find. Turning off java, reinstalling, downgrading and then upgrading OOo, deleting profile, different updates of java, you-name-it ... to no avail. I always end up with the same problem.
  • The most you can do then is probably to file a bug report then with OOo, and list everything you've tried, although in the absence of steps to reproduce on their machines they may be loath to try to track it down and fix it. It seems to me that this is probably a configuration issue, but at the very least, the OOo error message ought to be much more informative about what the issue actually is.

    For anyone finding this thread, there are easy solutions to the implementation loader issue on OS X (install the latest version of OOo) and Linux (make sure that openoffice-java-common and Java are installed), but the cause on Windows remains elusive.
  • Hi Simon, I think I am getting closer to the cause of the problem. When trying to install the extension, two uno.exe processes are started. On a OOo-help page (, it says:


    This may also happen when one wants to debug Java in the office process and therefore has provided the debug options for Java in the options dialog. The Java service of the extension will be registered in a separate process (uno.exe) which also needs to start Java. This Java uses the same settings from the options dialog. For example:


    If there is also a Java running in the office process, then the creation of the virtual machine in the second process will fail. The reason is, that the latter receives the same debug settings. It appears that two virtual machines, although in separate processes, cannot use the same port for debugging. If one changes the port number before adding the extension (and after the Java has been created in the office process), then the extension will be installed properly.

    The same effect can be seen when running "unopkg gui". When installing the second Java component then a second uno.exe is created and the creation of the virtual machine in this process will fail.


    However, I do not understand how I possibly could change the port?

  • I have the same problem with a Toshiba Portege R705, although Zotero works with my other computers. I fixed it once by removing everything and using the earlier plugin with Firefox, but the earlier plugin won't work with Firefox 5.
  • D-G
    edited August 3, 2011
    Ah, nostalgia. Yesterday I installed Firefox 5, OpenOffice 3.3.0 and the latest v6 JRE on a brand-new computer with Windows 7. After installing Zotero I tried to install the OpenOffice extension, but -- surprise, surprise -- it once again failed. Instead of relying on questionable uninstall/reinstall/reboot voodoo, this time I simply exchanged OpenOffice for LibreOffice 3.4.2. With the latter the installation of the extension simply worked the first time.

    Interestingly enough, on my old computer it didn't work with LibreOffice either -- but that was version 3.3 then. I have no idea if there was a substantial change with regards to Java between 3.3 and 3.4.2. Well, I don't really care. If LibreOffice works I'll take LibreOffice.
  • Thank you, thank you, thank you. I had tried with LibreOffice before also with no luck, but this time with 3.4.2, it did.
  • I had this problem with a native install of LibreOffice 3.3.3 on Pinguy Ubuntu.

    The installation seemed fine, the buttons came up, but they didn't do anything when I pressed them. I went to the the Extension Manager which claimed Zotero wasn't enabled and I got the error when I tried to enable.

    My fix was:

    Tools > Options > Java

    "Use Java Runtime Environment" was checked, however neither of the two runtime environments which appeared after a few seconds of detection were checked.

    I checked 1.6.0_26 which was the later of the two, was prompted to restart. Restarted LibOff. Enabled Zotero in the Extension Manager - went without a hitch. Restarted LibOff again. Zotero integration works!

    I hope this helps people avoid reinstallations.
  • edited November 9, 2011
    Comment for the assistance of others: I use Suse Linux 11.4 and LibreOffice 3.4.3. When my computer was upgraded to a 64 bit machine I found that Zotero didn't work although the icons still showed in LibreOffice. Trying to Enable Zotero from the LibreOffice Extension Manager led to the message "Could not create Java implementation loader". LibreOffice/Tools/Options/Java showed that a gcj java runtime environment was present and active (with the dot box checked).

    Workarounds such as uninstalling and reinstalling LibreOffice and Java, while deactivating & activating LibreOffice's option for "Use a Java runtime environment", had no effect.

    Although 64bit java-1_6_0-sun was installed and reinstalled, I became dismayed that LibreOffice would not even recognise the java file that was present. I also tried java-1_6_0-openjdk with the same issue.

    Finally two notes helped:
    1. LibreOffice Release Notes: "If you run Linux, the GCJ Java variant has known issues with LibreOffice, we advise to e.g. use OpenJDK instead."
    2. A web forum note that 64bit LibreOffice still requires 32bit Java.

    The problem was fixed by installing 32bit LibreOffice and a 32bit jre rpm (i.e. i586 rpm) on my 64bit system. I got the Java from

    (Note: if you also want to fix very slow record operations in Base then you will specifically need the older jre 1.6.22 at - for details of the fix see

    LibreOffice immediately recognised the jre java file after I pointed it to the new jre directory at /usr/java/default/bin The new jre automatically became the new default java with dot-box checked. The Zotero extension could then be Enabled in the LibreOffice Extension Manager.

    One issue remains, which is that the new jre isn't visible upon reopening LibreOffice/Tool/Options/Java. However, the new jre seems to be present because LibreOffice doesn't default to gjc java and Zotero continues to be active and work fine.

    So its back to full productivity with the wonderful Zotero app!
  • Dear all, I am running Open office 3.3 (latest version from Apache doesn't work) and Zotero 3. I'm getting the "Could not create Java implementation loader" all the time and have tried all the solutions above that I could, to no avail.

    Is there anything else I can do? It's getting really frustrating not being able to use the plugin.

    Does Zotero work with MS Office 2010? If so I may just buy that.
  • Did you try to install LibreOffice instead of OpenOffice ?
  • Libreoffice
    Zotero 3.0.7 (firefox addon)
    Windows 7 32 bit
    Zotero Libreoffice integration 3.5.1

    I just had similar problems installing zotero and libreoffice integration on this computer.
    I first tried to use zotero with the latest version of jre (currently 7update5), I got the error message "libreoffice requires jre to run this. this version of JRE is not compatible....). After some searching online, I uninstalled just the jre7u5, leaving java FX 2.1.1. Also deleted the profile folder for libreoffice to be safe. (found at ...users\(your username)\appdata\roaming\ (note this is a hidden folder so navigate to ...users\(your username)\ and type in the "appdata".)) I installed jre6u1. Now it works.

    You can get older versions of jre by searching online at other sites.

    If you uninstall both java fx 2.1.1 and jre 7u5, and then install jre 6u1, then it may not work. Leave the java fx2.1.1

    Subsequently I allowed an update of jre to 6.33 (or something like that), and it still works.

    What about zotero standalone? Same problem.

    This seems like a problem in compatibility between libreoffice and jre7u5.
  • I use zotero with portable firefox, portable libreoffice and portable java.

    When using java 1.6.0_31 there is no problem, when update to 1.7 the error appears.

    I have downgraded to 1.6.0_31

    I agree with Vijumoses in the compatibility issue.
Sign In or Register to comment.