Z2.1 : Master password dialogue shown for no reason


Zotero 2.1 will often show the Master password dialogue for no reason at all. I couldn't exactly figure out what triggers this, but it happens every time when the Zotero preferences window is opened, it happens often when the Zotero pane is opened, and it happens occasionally just out of the blue, for no apparent reason.

(Note that sync is set to manual, not automatic)
  • Zotero sync credentials are stored in the Firefox password manager. That's certainly why it shows up when you open the preferences, since all panes are loaded at once and the Sync pane has the credentials. It shouldn't need to happen otherwise if auto-sync is indeed off.

    We haven't done any testing with the master password dialog, but we can do so for a future release. However, I'd ask you to verify that you can get it to happen other than when opening the prefs with auto-sync off.
  • For some reason I wasn't getting the email notifications for some of the replies ...

    The master password dialogue will come up sooner or later in every session, without me touching the browser (i.e. it's not triggered by opening a website with a password field). I believe it's Zotero that does this. Sync is definitely turned off. But I'll try to disable all my other extensions for a while, to make sure that indeed Zotero is the culprit. I'll reply in a couple of days if I manage to confirm that it is indeed Zotero.
Sign In or Register to comment.