"Scitation" translator import failure

I got a translator error when I tried to capture this paper in Zotero.

("Time course of word identification and semantic integration in spoken language", J. Acoust. Soc. Am. Volume 108, Issue 5, pp. 2643-2643, available at scitation.aip.org, in case the link above doesn't work.)

The translator used appears to be called "Scitation", and I filed error report 744249333. (Some sort of regex match failure?)
  • Please go to http://github.com/ajlyon/zotero-bits/raw/master/Scitation.js and save the file to the translators directory of your Zotero data directory (http://www.zotero.org/support/zotero_data).

    It should start working again. If this works for you, please post here so that I can submit this change to be pushed to all users.
  • Worked great! Only quibbles are that it pulled out the date as "November 00, 2000" (but Zotero seems to have correctly interpreted this as a month+year), and that it didn't capture the PDF, which is always nice. But I bet it didn't do that before either. Thank you!
  • No, the old translator didn't do PDFs either. I don't know yet how feasible it is to set that up for Scitation. I may take a look, but no promises. If it doesn't happen soon, feel free to post here in a few months to remind me to look into PDF saving again.

    In the meantime, I've committed this updated translator to the Zotero repository, and it will be in the next Zotero update.
  • Any new progress on the PDF saving from Scitation?
  • No, not yet.
  • pdfs should now work for scitation.
Sign In or Register to comment.