Z2.1rc1 Partial Name cutoff


I just downloaded 2.1 rc1

Where more than one author's name appears in a cite, the first name of all the authors except the first are deleted. This is only in citations - in the bibliography entries, the full names are still included.This problem has not appeared in earlier versions.

I have tested this both with McGill-guide-v7, which I am developing, but also with Chicago (Full Note with Bibliography). I tried adding form="long" to the call, but that did not seem to make a difference.
  • I can confirm this. In a quick test, names added for disambiguation do not receive the first name. I've confirmed that Zotero is delivering the first name to the processor, so the problem must lie inside the processor itself.

    I'll look into this.
  • I have identified the source of the fault in the processor, in a reset operation meant to cope with styles in which first and subsequent citations have different et-al constraints. The saving of parameters is just happening at the wrong location in the code. I'll need to spend a little time thinking about the changes, but it's very clear what's happening, and it will get fixed, and soon.
  • edited March 7, 2011
    A fix for this issue has been included in a fresh processor release, and I see that the core developers have just picked it up on the trunk. The new code will be included in the next Zotero 2.1 release candidate which, given the fact of this particular processor bug, will likely be coming out soon.
  • RC2 of Zotero 2.1 is out. Is it confirmed, that it contains the fix for the name cut off? Changelog states, that Cite proc has been updated, but I do not see any difference in exported citations (but that may be error in my version of ISO 690 citation style definition).
  • I will investigate the behavior of the processor if there are reports of a fault, but you would need to be more specific. If you have a simple block of CSL and a small data set that produce incorrect results (not a whole style, and not an entire manuscript), you can post them here, or start a new thread. Otherwise, I'll be treating the set of disambiguation-related names issues that we experienced at the end of the beta phase as closed.
  • The problem, I am experiencing is that only first author is used in the citation. My macro to generate authors is:

    <macro name="author">
    <names variable="author">
    <name name-as-sort-order="all"
    sort-separator=", "
    delimiter=" - "
    <name-part name="family" text-case="uppercase"/>
    <names variable="editor"/>
    <names variable="translator"/>
    <text macro="title"/>

    I tried to use different citation style, installed with Zotero, for comparison, but with same result.
    Example data in Zotero RDF:

    <bib:Article rdf:about="#item_89">
    <dcterms:isPartOf rdf:resource="urn:issn:1335-4205"/>
    <foaf:surname>Šenovský, Michail</foaf:surname>
    <foaf:surname>Šenovský, Pavel</foaf:surname>
    <dc:title>Critical Infrastructure Risks</dc:title>
    <bib:Journal rdf:about="urn:issn:1335-4205">
    <dc:title>Communicationss - Scientific Letters of the University of Žilina</dc:title>
    <dc:identifier>ISSN 1335-4205</dc:identifier>

    I can simplify my CSL and upload it on my WWW server for easy reach, if it is necessary.
  • edited March 10, 2011
    Sure thing, I'll take a look. Can you put the style online, either on your server or at http://gist.github.com/, and post the link back here? For this, you actually won't need to simplify the CSL; we just need to take a look at the et-al values. (Edit: meanwhile, I'll take a look at what's going on with Chicago)
  • link to CSL:


    Thank you.
  • There is definitely something wrong here. Please wait for news.
  • edited March 10, 2011
    I haven't yet turned to your own style (I'll do that tomorrow, it's late here); but in Chicago Fullnote with Bibliography, it looks like the processor is doing everything correctly, but updates are not being populated back into the document. If I enter two references, each with four authors, all of which match except for the last, I get only one author + et-al for the first, and four names for the second. If I then open the first entry of editing, it expands to four names, both in preview and in the in-doicument citation.

    More news later ...
  • edited March 10, 2011
    Okay, news.

    The processor bug I mentioned above is unrelated; the processor was failing to update citations in which the number of names changed (for disambiguation) as a result of adding a new reference with a similar list of authors. I've fixed that in the processor, and the update will feature in the next Zotero release candidate.

    The issue with your style is not a processor bug, I think, but a couple of missing attributes in the style. If you add et-al-min and et-al-use-first with appropriate values to the bibliography element, the formatting should come out as you expect (there is no need to add the attributes to the citation element, since this is a numeric style).

    Currently, with no value for the et-al-min and et-al-use-first attributes, and without disambiguation, you will get the default, which is one name. This behavior may differ from the previous processor, but it is a sensible default. There are some items out there with upwards of 2,000 authors, and we don't want such items to lock up the user interface while a massive name list is being rendered -- in fact there was an error report on just that some time back, from a user of Mendeley, which also uses the processor.

    There is documentation on the use of et-al-min and et-al-use-first here (the spec isn't perfectly clear, but the attributes are normally added to the citation or bibliography element, rather than individual name elements). If you add those attributes and the style still does not behave as you expect, post again and we'll look into it. But I think that will get you going.
  • Not sure if this is related or not... using standalone 2.1a3

    I have a Book authored by two organizations. The Authors are entered as the acronym for the organizations.

    Author 1 = "XXXX"
    Author 2 = "YYYY"

    If I export the citation using the stock Harvard or chicago Author-Date style I only get

    XXXX. 2000. Title

    Should be:

    XXXX and YYYY. 2000. Title

    If I edit the author names to include an initial for the first name then I get the two names exported

    Author 1 = "XXXX, A"
    Author 2 = "YYYY, A"

    XXXX, A and YYYY, A. 2000. Title
  • edited March 11, 2011
    Thanks for reporting this, I'll check into it. This is a separate issue inside the code, but related insofar as it's about final tuning of names handling.

    (Edit: It will be a couple of days before this is addressed.)
  • Than you for your effort fbennett, but no luck.

    I remember experimenting with et-al-min and et-al-use-first attributes in the name element. As per your advice I added it to citation element using 3 for min and 1 for first (and later set et-al-use-first to 2m just to be sure). The behavior did not change.

    Updated style:

    I also tried to export citation using all styles preinstalled and there was not single case where I got both authors in citation.

    Perhaps it is same bug as grubs reports?
  • I'm leaving on an overseas trip, and will be out of touch for several days. Will get to this when I'm able.
  • I have just push out a release of the processor (1.0.125) that fixes the problem with the restriction to a single institutional author.

    I likely won't be able to look at senovsky's style for a week or so (I'm on the road, and quite busy with other work), In sorting out the latest error report on that above (i.e. "no luck"), let us first confirm that the names used for testing are personal names, entered in two-field mode in Zotero, and not institutional names. That will eliminate the (separate) institutional names issue from the roster of possible causes. (In the test framework, there are no problems with rendering the correct number of names, so if there is still a problem with senovsky's style, it will need some investigation to arrive at the cause.)
Sign In or Register to comment.