Bug report - Citations all have "a"'s in them

I just upgraded to the latest beta of the Open Office integration. Now, when I add citations to my document (using Harvard), they all have a's in them. For example: (Smith 2010a); (Jones 2011a). This is the case even for a citation by the same author, same year, but two different documents - ie, (Lee 2010a; Lee 2010a).

This is happening in the bibliography, as well:

Galloway, A. & Thacker, E., 2007a. The Exploit: A Theory of Networks, Minneapolis: University of Minnesota Press.

OS: Ubuntu 10.04 64 bit
Open Office 3.2
Zotero 2.1b6
OO extension 3.1b1
  • I have almost the same problem, but all citations have a 'b' added, which is even stranger (where is the 'a' to begin with?). Most of the pre-existing citations in the document have had a 'b' added on conversion to the 2.1 format, but some don't; no pattern discernable. All newly added citations get a 'b' though. I cannot tell whether this is caused by a recent beta or not as I only just started testing 2.1 with the beta 6.

    Mac OS X 10.6.6
    MS Word 2011
    Zotero 2.1b6
    Macword integration 3.1b2
  • I have so far been unable to reproduce this. Is this with an unmodified (or freshly revalidated) version of the Harvard 1 style?
  • I didn't modify the style. This happened right after upgrading to the latest beta. The exact order of actions:

    I inserted a multiple citation for one author. It appeared in the document like this:

    (Smith 2010b; 2010a).

    I didn't want that order (and I'm not sure why the 'b' came first), so I used the new ordering feature to rearrange them. Then, it looked like this:

    (Smith 2010a; 2010a).

    I thought this needed to be updated, so I updated all citations. After that, everything had 'a''s in it, even in the bibliography.

    Now, many of the a's have disappeared, but some still remain.
  • Can you replicate this in a new document?
  • Yes -
    I did the same thing in a new document. Harvard 1. I added a citation with the same author, and it came out (Miller 2010b; Miller 2010a). I edited this citation to change the order, and that worked: (Miller 2010a; Miller 2010b). I then added a new citation, and even though it's the only one by the author, it comes out (Sullivan 1972b). This is reflected in the bibliography as well.
  • Confirmed, thanks for the followup. I'll get on this right away. If the fault is in the CSL processor (which seems virtually certain, from the symptoms), I should have a fix out within the day, for inclusion in the next beta release.
  • Initial testing shows that removing the et-al-subsequent-min="3" and et-al-subsequent-use-first="1" lines will make the lingering year-suffix go away. If you need things working immediately, you can remove those two lines from inside the citation definition, and the output should come right for you.

    Not a permanent answer, of course; but I have a test for the error running now, and a fresh release will come soon.
  • Have identified the source of the fault, and shipped a processor update. Many thanks again for providing the steps that replicate the error.
  • Great! Thanks for your hard work on this. Let's hope this bug stays dead.
  • Oh, looks like this was solved over the weekend! I can confirm that removing the et-al-subsequent-min="3" and et-al-subsequent-use-first="1" works as a temporary solution until the next release hopefully permanently fixes this.

    Thanks a lot!
Sign In or Register to comment.