Problem with custom style in 2.1b6

Just downloaded and tried 2.1b6. There is still a problem that I reported earlier with 2.1b5.

I'm using Mac OSX 10.6.6, Firefox 3.6.13 and Office Mac 2011 14.0.2

For Zotero 2.09, I have PythonExt and Zotero MacWord Integration 3.0b7 installed.

For Zotero 2.1b6, I have PythonExt 2.6..20100203 and Zotero MacWord Integration 3.1b1 installed.

The Style can be found at:

With 2.09, the output (citation and bibliography) looks like this:

While with 2.1b6, the output looks like this:

As you can see, the bibliography with 2.09 has the author (an institution) as upper case/small caps while the 2.1b6 bibliography is upper case/lower case. The 2.09 output is the correct one so something is happening to overrule this in 2.1b6.

I note that this only happens with institutions. The upper case/small caps seems to work OK when authors are people in 2.1b6.

If this can be resolved I think I'm 'good to go' with 2.1x.
  • I've looked into this a bit more. The difference can actually be seen within Firefox using the built in Zotero Reference Test Pane (chrome://zotero/content/tools/csledit.xul).

    Choose the 'American Journal of Botany (dev)' style and then look at a reference with an institution as author (Bibliography). The Uppercase/small caps format occurs with 2.09 but it is Uppercase/lowercase with 2.1b6. The suggests to me that the issue is not with the style but with the beta version of Zotero.
  • Thanks for reporting (and for your patience). This is definitely a processor issue, and will be fixed in a fresh release later today. Look for the fix to appear in the next Zotero beta.
  • Great!!

    Thanks for your assistance as always.
  • edited February 14, 2011
    I've just put up a fresh processor release that fixes this. It should work its way into the next Zotero beta.
  • Just downloaded and tried 2.1b7. Issue resolved.

Sign In or Register to comment.