2.1b5 problem "An error occurred generating your bibliography. Please try again."

I have got a very odd problem with a style I am currently testing for my students in France. On a firefox restart, if I select an item in the middle column, right-click and choose "create a bibligraphy" and then the style here git://gist.github.com/808239.git everything works as intended, I can copy to clip-board and the result when pasted is what I need. When I then go back to the same entry and repeat the steps, I get a Java-Script error pop-up specifying "An error occurred generating your bibliography. Please try again."
Needless to say trying again didn't solve the problem.
I ran debug on the whole procedure and have posted that , ID is D1789152145

System is Windows XP, Firefox 3.6.13, Zotero 2.1b5, no personas or other extensions
  • Can you generate a report ID? The debug ID doesn't contain the information we need, but a regular report ID should.
  • Report ID is 1680588203 and I think I can now see what is doing this. It seems to be linked to one of the Bibtex citekey translators I was using and which have also recently stopped working for me. I suppose the first step is to remove the translator?
  • and a new Report ID 689734431 now that I have removed the translator. Not sure what to do now?
  • It might not matter, but validation (http://www.zotero.org/support/dev/creating_citation_styles#validation) shows your style contains an error:

    # Error: Attribute plural not allowed on element term from namespace http://purl.org/net/xbiblio/csl at this point.
    From line 22, column 13; to line 22, column 63
    <term name="page" form="short" plural="contextual">↩
  • Thanks for that, I have removed the offending item and the style here git://gist.github.com/808417.git now validates, but it refuses to install, "does not appear to be a valid style file." - surely if it validates it should be a valid file and install?
  • edited February 2, 2011
    Try downloading https://gist.github.com/raw/808417/gistfile1.txt (File > Save Page As... > "ehess-histoire.csl"), and drag the downloaded "ehess-histoire.csl" style onto an open Firefox window. That installs the style for me (under Zotero 2.0.9).
  • tried, same error as before in the 2.1b5 beta, "does not appear to be a valid style file.". It must be beta-specific, but I don't know what to try next.
  • edited February 2, 2011
    we'll have to wait for one of the devs to tell us what's in the error report.
  • The error report has a syntax error in citeproc-js while parsing the style. I can reproduce the error, but it looks like there's no difference in the XML being parsed between the first and second time a bibliography is generated, so I am a little puzzled.
  • The original problem (upon creating a bibliography) indicates this in the error report:
    [JavaScript Error: "syntax error" {file: "chrome://zotero/content/xpcom/citeproc.js" line: 415}]

    is there a way of getting an error report from a style which refuses to install?
  • edited February 2, 2011
    You can get an error report when the style refuses to install, too, but it's essentially the same (a syntax error, now in style.js) and you can probably fix it by restarting Firefox. This is beginning to look a lot like a Firefox bug.
  • edited February 2, 2011
    edit: never mind - what Simon says.
  • hmmm - so essentially there is something in my style which throws firefox off kilter?

    Does it help that the style installs and works in my copy of 2.1b1 - just in case the whole issue is somehow linked to this whole issue http://forums.zotero.org/discussion/14427/problem-with-numberofpages/ Could something have gone wrong with number-of-pages?
  • edited February 2, 2011
    Maybe. Does the problem go away with a version of the style without the number-of-pages variable?
  • the installation problem still occurs without the number-of-pages.
    That said, the installed style has the number-of pages in it, and that's the one creating the errors upon creation of a bibliography.

    There seem to be several problems here...
  • The issue is now fixed on the trunk. In another part of the code, we were setting global properties that interfered with parsing your style because of whitespace, but apparently weren't affecting other styles. This part of the code didn't exist in 2.1b1, which is why it worked before.
  • oh brilliant, thank you so much.
    So when 2.1b6 comes out, my style should work with that?
  • Yes. In my brief testing ,it also seems as though it should work with 2.1b5 if you remove the newlines.
  • I am also having this issue with copying references in "chicago note w/o bib" style to clipboard in 2.1b5, although I can still access notes properly from within the libreoffice plugin. Same error message. Please let me know if you want a report generated, but it looks like the same problem.

    ubuntu 10.10, Zotero 2.1b5, firefox 3.6

    Simon, could you please clarify where the newlines/whitespaces that need to be removed are located? in the style? the citation? code? thanks.

    Looking forward to 2.1b6...
  • 2.1b6 was just released - if you're in a hurry you can go to tools-->add-ons and click update, otherwise FF will prompt you soon.
  • downloaded 2.1b6 and still get the error. the error report is 1404684422. Running Ubuntu 10.10. I get the error when I try to create a bibliography (copy to clipboard, rtf, html, and print all produce the same error). THe message is "[JavaScript Application] An error generating your bibliography. Please try again" Trying again reproduces the error. I can still retrieve and insert references via the OO (LibreOffice) plugin. Just cannot create a bibliogrphy from within zotero.
  • fixed in 2.1b7/Ubuntu 10.10. Thanks!
Sign In or Register to comment.