Accesing My Library on Zotero Website

I can never seem to be able to access my library on the web although I'm able to synchronize my Zotero collection. I just see a blank screen, and this happens with different browsers and computers. This has actually been going on for a while but never bothered to post it here until now.

What is causing this? I know there was a major server problem until earlier this week, but that is now solved right?
  • I have the same problem. I had a similar issue with a blank page (plus stucked synchronisation), which was discussed within another thread here (see: It has limited my usage of Zotero for 175 days. Today, it seems that I can synchronize well, but still I am not able to display my library on the web. I can only see my two collections, but nothing from my library. Furthermore I have to say, that loading of my library on the web had been pretty slow sometimes. Now it is still slow, but furthemore the result is a blank page.
    I will appreciate any attempt to help.
  • edited January 25, 2011
    The sync server these pages depend on is still under very heavy load. This should improve as the week goes on and the new server architecture takes more of the load off. The blank pages were caused by a configuration mistake that has been corrected, and when the sync servers are under too heavy a load it should give an error message instead of a blank page. Obviously that is not a solution, but it should at least give some feedback as to the issue until we can improve the situation.
  • Thank you very much for your feedback. Now it will be easier to wait for improvement of the synchronisation functionality. But the problem with blank pages still exists on my PC, although (according to your message) it should be solved.
  • Yeah I just tried and still saw the blank screen :(
    Thanks for making the efforts to solve this issue. I hope this will get fixed soon!
  • I have the same problem. I just tried to view My Library on the web and even after re-freshing several times, logging in and out, etc. all I get is a blank screen. I used to be able to see my library on line.
  • same problem here, only I also have problems with synchronizing with the server, nothing really happens. I only encountered this problem today, when trying to set up Zotero on a new computer, it seems it is still working fine on the old one.
  • Just to let people know, there is another thread discussing this issue:

    Since this point has been raised in the other thread, it might actually be worth indicating the number of entries we have in our Zotero collection?

    I have over 5000 entries at the moment (5068 to be specific), but I've been experiencing this problem ever since Zotero implemented the sync feature. I remember I used to be able to access My Library on the web at the beginning even if it took a few tries before I actually saw my collection. I probably had around 2000 entries at that point.

    As my collection kept on growing, I guess the online access became virtually impossible (as in I now always get a blank screen). It's been months since I last saw my collection online.
Sign In or Register to comment.