Icon shows up, but Zotero can't grab the right data (or any data)

Have a site for which the little icon thingy shows up in the location bar, but clicking on it either doesn't create a new library item or creates one with the wrong information? Add it to the list here...
  • From user shel in another discussion:

    Cleveland Sate University -- Scholar Library does not work
    OhioLink--the statewide library system does not work
    Ohio State University Library catalog does not work
  • From user matt_price in another discussion:

    University of Toronto : http://www/library.utoronto.ca works only with detailed view (of individual resources)
  • Zotero gives an error in historycooperative when trying to import an article with a title that includes quotation marks (I assume this is the problem because all other articles from the issue import correctly). I get a message "an error occurred while saving this item":

    Title: "Sentiments of a Private Nature": A Comment on Ann Laura Stoler's "Tense and Tender Ties"
  • edited October 17, 2006
    I've had difficulties getting anything off the World Cat website also. Although, I'm logged on through the Ohio State library system and, as noted above, their library isn't currently on a list of working websites. Still, I wouldn't think that the World Cat system would be dependent on my library's. Has anyone else been able to pull stuff off World Cat?

    Also, I can't get anything off JSTOR.
  • I'd love to see the McGill University Library catalogue (http://aleph.mcgill.ca/F/) work with Zotero.

    Currently, the book icon comes up when viewing a library record. However, when I try to save it to Zotero, it says "saving item" for a long time, then eventually says--

    "An error occurred while saving this item. Please try again. If this error persists, contact the translator author."

    The McGill catalogue is powered by ExLibris Aleph500 v16.2.
  • this doesn't fit here but don't know where else to put it ... it is not a case of the logo showing up but rather the logo not showing up ...

    I can see how Zotero works for Amazon.com but when I try to use amazon.co.uk or amazon.fr which are the sites I use most often, none of the Zotero icons appear so it is not possible to save the details of the books found on these sites as easily as if I found them on the US site.
  • As noted in the Ebsco thread, I was unable to save an article from EBSCOhost's Academic Search Premier database. Zotero tried to save my item but I eventually got the same "error occurred when trying to save" type message.
  • cm, we will be steadily adding more international databases to the list of compatible sites. I'll add Amazon.co.uk and Amazon.fr to the request list.
  • We added a completely rewritten translator for Amazon to the central repository today. It uses the Amazon API rather than page scraping, so it should be considerably faster, and it should also work with international sites.

    Zotero should automatically update to the new translator within the next 24 hours if the automatic update pref is enabled. (We'll be adding a manual update button in the next release.)

    Let us know if you run into any problems with the new translator.
  • Seems like Google Books does not work anymore after todays update at Google Books?
  • Yeah, looks like it. We'll try to get a new translator out ASAP.
  • Re: international Amazon sites, after my previous message above we unfortunately had to revert to the original Amazon translator (which doesn't work with international sites) due to a Firefox bug that limits the size of translators we can send from the repository.

    We'll roll out the new Amazon translator (along with a workaround for the size limitation) in Beta 3, which should be out within a couple weeks, so other Amazon sites should start working then. Sorry for the delay.
  • ISI Web of Science support was added in Beta 3, thank you so much! Now I can actually use Zotero for something :)

    After short testing it seems to mostly work except for:

    1. If the author(s) is in the form "Winter G (Winter, G.)" (first is a hyperlink to search) then Zotero works ok, but sometimes the author is expressed in link-only form such as "Winter G", and then Zotero can't grab it.

    2. Go to ISI, search, get a list of results, open one item, save in Zotero. Browse back to the list with the Back button and receive a notice from Firefox about the page containing POST data, requiring pressing Ok before getting back to search results. If you don't save the data with Zotero, there's no notice of POST data. Minor annoyance only.

    If the first point is fixed and no other bugs turn up, I'm ready to spend a day to create a personal library, and to recommend Zotero to all my colleagues. Thank you again!
  • Yale University library catalog: http://orbis.library.yale.edu works only with detailed view of individual resources - 'folder' save of multiple titles generates error.
  • jsimonen: Our ISI Web of Science translator should now resolve the problem you were experiencing. Your Zotero installation should have automatically updated to the new translator by now.

    ksprague: We are aware of our lack of full support for Orbis (see http://www.zotero.org/index.php/translators/), and we hope to have a fix soon.
  • I ran into this problem as well on the MELVYL system. It looks like the translator for Aleph systems calls the MARC binary module, and those systems don't issue a true MARC record. I can't find a screen scraper for MARC display format, nor for the Aleph bib display. If I can figure out what's going on I'll write some documentation for it -- documentation in the code is minimal.
  • I'm wondering about the melvyl system, too--this is a heavily used database, and, imho, should really be supported. Is the problem that tricky to overcome?
  • The catalogue of UniversitĂ© du QuĂ©bec, using Aleph 18 isnt supported : http://catalogue.uquebec.ca
  • I have no Zotero icon in my url bar. Also, newly saved items in Zotero don't show up when I try to insert them as citations. Can you help?
  • please start a new thread ("new discussion" button at top left) after running through these: http://www.zotero.org/support/troubleshooting_translator_issues
    in that thread, please provide the information requested in the last step.
This discussion has been closed.