Cambridge University Press site translator broken?

The translator for the journals page at Cambridge University Press ( has previously worked fine but now appears to be broken. I suspect this may have happened when they gave the site a facelift a few months ago. Is there a way to fix it (I rely heavily on important references from this site)?

With grateful thanks, Martin
  • I am just commenting on my own post here - to ask whether anybody is aware of this problem. With thanks, Martin
  • Can you provide a URL for an article that doesn't work? I just tried and it works for me.
  • ajlyon - while you're at Cambridge (works for me, too, btw.) - could you have a look at pdf import - obviously it'd be great if you could get that working again, but if that's not possible, it would probably make sense to turn off the extra snapshot the translators grabs trying to get the pdf.
  • I just looked into fixing PDFs, and it looks like they check the referrer header and won't let Zotero see the PDF. This isn't that uncommon-- but I don't think the translator infrastructure lets us set such headers yet, so I don't think I can do anything about it until that happens.
  • If it wasn't clear, my comment is a request for comment/feature request from/for the Zotero core devs, since I don't know how to proceed.

    I can remove the snapshot for now, but I'd like to fix it properly.
  • I have done some experimentation, herewith:

    1a) If I go to a single article at CUP ( I see the little page icon in address bar and when I click the ref is saved to Zotero .

    1b) If I do the same with standalone zotero and chrome I see the page icon but the ref is not saved when I click it.

    2a) If I go to an issue of the journal Oryx ( with firefox or chrome I no longer see the little folder icon that in the past, when clicked, provided me with a window from which I could choose multiple items for import.

    2b) But if I go to an issue of the same journal as supplied by ajlyon above ( I do see the little folder icon and can choose articles (with firefox but not with chrome and standalone zotero).

    I have not experimented further and I have not attempted to check the download of PDFs.

    My system is Linux (Ubuntu 10.10), Firefox 3.6.13, Chrome 8.0.552.237 (70801), Zotero 2.1b5 and Standalone alpha2

    I would be happy to check or experiment further if anybody wishes me too. My desire is to be able to download articles with their associated PDFs
  • 2a) I can reproduce, but not sure if that's really an issue - that's the journal starting page that happens to have the articles from the current issue on it - if you take a closer look, you also cannot select and export those articles as you can with the regular issue display, so I'd guess that would be hard to fix even if we wanted to.

    For the standalone issue stay tuned - ajlyon has been wanting to track that down for a while now, so I'm sure he'd be happy if you helped him troubleshoot.
  • Many thanks and WRT 2a you are correct - very useful to know - if I click on the Current Issue button the same articles are there but now I see the folder icon.

    As I was on the case I checked out the PDF import (I have full access to the CUP journal I checked) and PDFs are not imported.

    I am happy to do help with troubleshooting in any way I can.
  • re 2b: It works for me, using Chrome and Standalone 2.1b5+ (multilingual, but it shouldn't matter). Hmm...
  • could there be a chrome vs. chromium difference? Or Chrome version related?
  • ajlyon you state Standalone 2.1b5+ but I am only aware of 2.1a2
  • Oops. I mean that I'm using Zotero 2.1b5 in Firefox, with the connector hidden preference enabled. I should try with standalone proper. I'll explore this with standard standalone.
  • Just to let you know: With Chrome and Standalone 2.1a3, which I have just installed, on Ubuntu, clicking the folder icon in the address bar at, for example,, now produces the window where one can click multiple items (although window takes a long time to appear) and they can be saved to Zotero. PDFs are not, however, downloaded.

    Yours, Martin
  • I just looked into fixing PDFs, and it looks like they check the referrer header and won't let Zotero see the PDF. This isn't that uncommon-- but I don't think the translator infrastructure lets us set such headers yet, so I don't think I can do anything about it until that happens.
    Devs? Is this something that we can do? We can move discussion to zotero-dev, but some guidance on this would be helpful.
  • Many thanks and I will wait for further news.
  • We could potentially set the referrer to the page being translated automatically. Would this be sufficient to make this case work?
  • I think it should be. I understand that we don't want to allow wholesale X-Referrer forgery, but this seems fairly honest. When I have some time tonight, I can try doing exactly that with curl.
  • Please go to Journals Online.js and save the file to the translators directory of your Zotero data directory (

    It should start saving PDFs (and working on search results and tables of contents) again. If this works for you, please post here so that I can submit this change to be pushed to all users.
  • Many thanks for this. I have tested it: References are saved but not the PDFs. If you want to check this for yourself you can go to the January 2011 issue (Volume 45 Issue 1), which is free to read and thus the PDFs are freely available to all (
  • Try installing from the link above again. It appears that I had PDFs working only for paywalled items-- it should now work for all items.
  • This now works great, thank you! I have tried it when not logged in (on the Free Jan 2011 issue) and when logged in with my subscription (on a couple of issues). All items added and PDFs downloaded! Again, a big thank you. Martin
  • I have just noticed that the Abstract field is not being imported from the CUP web site. Does this lie within your remit, here, ajlyon, or should I report it elsewhere? With thanks, Martin
  • Try installing again-- abstracts should be working now.
  • Indeed they are - thank you again! Martin
  • I see this thread has been dormant for a year, but I'm having a problem with Cambridge UP Journals. I'm using Zotero Standalone 3.0.8 with Chrome. If I go to the table of contents page for an issue of a Cambridge UP journal, I get the folder icon in the address bar. When I click on the folder, however, the window that pops up is empty. It has no articles for me to select from those on the page. Here's an example:

    If I go to specific articles within the issue of the journal, I can import them into Zotero without a problem. Any ideas? Thanks.

    I tried installing the new translator linked to above, but that doesn't seem to have fixed it.
  • Thanks for reporting this. It should be fixed in Zotero Connector, available now.
  • Thanks. I think I was running before (at least that's what Chrome said), but I deleted and reinstalled the connector and now it's working like a charm.
  • A problem with Cambridge Univeristy Press (CUP) journals that has occurred in the past now appears to be reoccuring. The translator downloads the citations but not PDFs. This issue of the journal ( for which all PDFs are freely available, is an example. I tried another journal on the CUP site and the same problem occurs.

    Does anybody know if there is a way to fix this?

    With grateful thanks, Martin
  • Hello everybody: this is just a follow-up to enquire whether anybody has any thoughts on my query above, as it remains pertinent.

    With thanks, Martin
  • It's on my list. I'm just behind with said list.
Sign In or Register to comment.