Import broken?

With Zotero 2.1b4 on Firefox 4.09b on OSX 10.6.6 any kind of file import seems completely broken. Be it .bib, .ris or MODS, when I try to import the data, nothing at all happens. No error message, no status bar, nothing. I tried all kind of resetting, still no result. The only thing that worked was going back to Firefox 3 and Zotero 2. Then the import worked fine.
  • Thanks for this report. I just fixed this on the trunk. We'll probably put out another beta relatively soon to resolve this.
  • Seems like it is also broken on the alpha (standalone) version. Can the fix be ported to this too (I use Z. on Win 7).
  • It will be. The trunk is for both.
  • Is COins import also broken? It doesn't seem to work here …
  • No one else having problems with COins import?
  • COinS works for me. Tested on the project page:

    Can you provide an example URL?
  • COinS works for me. Tested on the project page:
    Doesn't work here with Zotero 2.1b4 on Firefox 4.0b8 on OSX 10.6.6
  • I´m using Zotero 2.1bb with Firefox 3.6.13, and for a few days, the import does not work anymore.
  • There seem to still be widespread import problems with 2.1b4, but I think they'll be resolved with the imminent release of 2.1b5.
  • Dear developers, please hurry up with releasing 2.1b5. Many functions are broken in 2.1b4 and this stalls the productivity of many beta users. I am counting on you guys for help and wish you all the best!
  • 2.1b5 appears to be in the pipeline-- it was tagged in the repository and even seems to be available at -- but maybe that's not the final version of 2.1b5, so you may want to wait for an announcement.
  • That's great, thanks for the quick update! A remaining issue (at least for me) is that the automatic .RIS import still does not work. The only way around this is saving the .RIS file and then manually using the "Import" function in the Zotero menu. Do more users have this problem and can I do something about it?
  • Provide an example.
  • I am using Google Scholar and have selected RefMan for citations import in the search preferences. When I search a reference and then click on "Import to RefMan", Firefox doesn't recognize the file ("scholar.ris") and asks me what to do with it. Zotero used to automatically import the contents of the file into the Zotero library currently selected.
  • Do you have Use Zotero for Refman/RIS checked in the Zotero preferences?

    Also, is there a reason you can't use the site translator for Google Scholar (folder icon in the address bar)?
  • Already fixed by Simon on the trunk. Thanks.
  • The site translator in the address bar works perfectly fine - only the "Import to RefMan" option doesn't work. Good to hear that it has been fixed already :-)
  • With 2.1b5 COins import works again for me.
Sign In or Register to comment.