2.1b4, Firefox 4, Ubuntu 10.10: Component load error

Hi all,

I have a working Java install on Firefox 3.6.13, running under Ubuntu Maverick (10.10) which I use with the OpenOffice plugin. I decided yesterday to try Firefox 4 beta 9, but sadly couldn't get around the component loading error in Firefox.

Things I have tried:

-- about:plugins shows the Java plugin loaded succesfully
-- various Java testing sites report that Sun Java is working fine
-- I have removed all IcedTea/OpenJDK plugins and runtimes
-- I have tried disabling apparmor for the Firefox profile (although could this be FF3 specific and that FF4 is still in enforce mode?)

The error seems to be "Error calling method on NPObject" on line 227.

Any ideas? Has anybody got this setup working?

Best wishes,

  • edited January 16, 2011
    I'm pretty sure Frank has this set-up working for him, but you're not alone with your problem:
  • Thanks Adam; I wonder what's different. It does seem very similar to the problem detailed on the other thread (Java working, etc.)

    Do you know if apparmor has a default set of enforcement policies that could be interfering?
  • I don't know anything about app-armor.
    Things have always worked for me out of the box on my 10.04 (and prior) ubuntu and I'm scared to change now ;-) it used to be that the people who had this not working missed something in the instruction - now everyone who reports this problem seems to have done and read all the right stuff, so maybe this could warrant some developer attention.
  • You'd have to generate a report ID for me to confirm this, but I am pretty sure you're running into bug 620773, the patch for which didn't make it into Firefox 4.0b9. A nightly build should work, or alternatively, you can wait for 4.0b10.
  • Hi Simon,

    Many thanks; a nightly build fixed the problem -- now testing the Zotero beta in Firefox beta. Call me stable!

    Best wishes,

Sign In or Register to comment.