2.1b4 Mac: Can't drag-and-drop references into collections (also applies to standalone version)

I have both a PC and Mac running 2.1b4, and this problem only applies on the Mac (running Firefox 3.6.13 and OS X 10.6.6).

When I try to drag a reference into a collection, nothing happens (I can't even begin to drag it). This only applies to references, though---I can still drag notes.

(I did not have this problem on 2.1b2.)
  • edited January 17, 2011
    UPDATE: It turns out the same problem occurs when running the new standalone Zotero (again, on Mac running 10.6.6).

    Is anyone else experiencing this? It would be great to get it confirmed and addressed.
  • I have the same problem, although for me it only occurs when a search filter is enabled. So, if you remove the search you can drag the items again. This is for Standalone version.
  • Interesting... What's your operating system etc? For me the problem occurs whether or not I have a search filter, and this goes for both Firefox and standalone.
  • OS X (10.6.6).
    Google Chrome (8.0.552.237).

    Looking at it again, it appears to be very "picky", sometimes working with search, sometimes not.

    Here's a screenshot: https://skitch.com/quinndupont/rj33h/zotero
  • I'm seeing the same things. I am running Mac OSX 10.6.6.
    In Zotero inside Firefox, I can't drag and drop anything. In stand alone Zotero, I can drag items with zero attachments but can't do so if there is an attachment.
  • There's a current bug that prevents drag-and-drop from working the first time you try to drag an item after a Firefox restart, but after that it should work.

    We haven't reproduced any other drag-and-drop problem.

    Provide Report IDs and explicit steps to reproduce, and check your Quick Copy settings in the Export pane of the Zotero prefs and see if the setting there makes a difference.

    quinn_d: What is that screenshot supposed to show? It appears to show dragging working normally.
  • Thanks, Dan. That worked! I tried changing the Quick Copy settings to disable Quick Copy when dragging more than 0 items, and now I can drag and drop normally. I'll try to do some further testing later on (note, for the record, that I had never adjusted the Quick Copy settings in the past, so this may continue to be an issue for users with similar setups).
  • Report ID: 681450747

    Firefox 3.6.14, Zotero 2.b14, Mac OSX 10.6.6

    I am able to drag and drop if my Default Output Format (under Export inside Preferences) is selected as Wikipedia Citation Template. I can reproduce the failed drag-and-drop behavior if I select BibTeX as the Default Output Format.

    @Dan Stillman: thank you for your replies and support for Zotero.
  • Hi,

    I too appear to be having an issue getting drag and drop references to work in both the Stand Alone version 2.1a3 and the firefox plugin 2.1b7 on my Mac OSX 10.6.6 firefox version 3.6.13.

    I'm able to drag if I change my quick copy options to disable when dragging more than 0 items but this then does not paste the (in my case) BibTeX information into the document I drop it on.

    This could be that my memory isn't serving me well and this was not how previously I was able to drag and drop BibTeX information - but I was just doing it yesterday when I had the latest 2.0 version of the firefox plug-in so I think I can remember how to do it correctly!

    For now my work around is to export my bibliography or the just the item itself as bibtex, open that document and copy paste.

    Thanks in advance for any advice!

    P.S. I can create a Report ID (and learn what it is) tomorrow if necessary.
  • To create a Report ID, select Report Errors from the gear menu.

    I'll see if I can replicate this.
  • I was able to replicate this, and it should be fixed for the next beta.
  • This also happens with the Linux version, btw. I usually use quick copy to copy BibTeX entries into my bib files. This stopped working when I upgraded to beta 7 in order to try out standalone Zotero with Chrome. At the moment, quick copy does not work in either the Firefox plugin or standalone.

    Will the mentioned fix will also fix quick copy on Linux?
  • I'm having this problem with multiple computers under Linux as of Firefox 4.0 RC with Zotero 2.1rc2, but disabling Quick Copy did not fix the problem. Nor did restarting Firefox. Thanks for the help, as always!
  • cgranade, can you be more specific about what you are trying to do and what the problem is? I can't reproduce the originally reported issues on 2.1rc2 on Linux.
  • Simon: Thanks for the help! When trying to initiate a drag and drop of an item in my library with the intent of copying it to a different collection, no icon appears under the mouse cursor to indicate that a drag and drop even has started. Furthermore, releasing the mouse over a target has no effect. Please let me know if I can provide more info!
  • Can you try generating a report ID?
  • Done. Report ID is 454730577.
  • There's no Zotero error in that report, so it's not really of much use, although that's probably because no error is getting triggered. Does this happen for any item and any item type (including e.g. standalone notes) in any collection? Does disabling other extensions and appearances change the behavior?
  • Sorry for taking so long to reply. After restarting a second time, the problem went away. I wish I knew how to reproduce this problem reliably! Thanks for your patience.
  • This does not seem to be fixed. I regularly encounter the problem with Standalone 3.0b2.1 on Xubuntu Natty 64. Sometimes I cannot drag & drop into collections or tags. All it takes is a restart of the application and it works again, but I can't figure out why it breaks.
  • Jay, provide a report ID after re-triggering the error.
Sign In or Register to comment.