Component-loading error despite all previous linux-solutions

Dear readers,

I have the component-loading error with OpenOffice 3.2 on Ubuntu 10.10 and I tried all previous solutions to this problem described in this forum and on the troubleshooting page. I am somewhat desperate now since I tried everything other users described but nothing solved it on my machine. I would very much appreciate support.

System: Zotero 2.0.9 in English language version with OpenOffice integration 3.0b2 in Firefox 3.6.13 for German-language OpenOffice 3.2 on Ubuntu 10.10

Error: Toolbar does show up but upon clicking on “insert citation” I get the known error message

“Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed, and then try again.” was shown (in local language).

Java: sun-java6-plugin and sun-java6-jre; This is recognised by OpenOffice and the Java test-page says it works, IcedTea and OpenJDK were deinstalled

AppArmor: I tried both “sudo aa-complain /etc/apparmor.d/usr.bin.firefox” and “sudo /etc/init.d/apparmor stop”

Re-installations: I re-installed the OO-integration, Zotero itself and OpenOffice.

None of the above removed the problem. I do not know what I can do any more and would appreciate advice enormously.

With best wishes and many thanks in advance,

Sign In or Register to comment.