How to deal with the 'read only' error in OpenOffice pluggin?

I upgraded to rc5 when it came out. Everything was going fine.
Upgraded the OpenOffice pluggin last nite, then I could not generate bibliography and footnote anymore. When I click on any of the pluggin icons, it just said 'Read-Error: this citation is read only'. Stuck, no idea what's wrong. Can anyone help?

(using OpenOffice 2.3)
  • Having the same problem.

    Actually the error is in tha macro script and saying "This property is read only" referring to the line:
    Mid(fnRemoveString, nTagStart, nEnd - nTagStart + 1, "")

    How do I solve this?
  • Actually now I managed to make it work again by unistalling and reinstalling - but I lost all my in-document citations. Strange! I had a backup of course, but still... I guess it is beta and no great harm done really since I can fix this in half an hour.

  • I'm having the same problem. Funny thing is that every once in a while it works again 1 time.

    Rytmisk: What exactly did you uninstall and reinstall? Zotero, Openoffice, Openoffice extensions or the whole lot? What was it you lost? I just want to know if this is an option.

  • I unistalled the extension and reinstalled it. Usually that doesn't do anything to the references as such, but this time it went bananas and I had to manually enter every reference in the openoffice document all over again. The database was intact though since the mozilla plugin worked fine.

    Good luck
  • Weird stuff. I've uninstalled and reinstalled a couple of times and I've tried both in Openoffice (for Mac) and Neooffice, but nothing helps, except a couple of times when it worked once but then stopped.
  • Thank you thoms! That fixed it! First time I've edited a macro.

Sign In or Register to comment.