Bibliography Question

Hi, I've been curious about this issue for a while but never bothered to ask this until now. I usually use the MLA style to cite my sources but I'm wondering if Zotero is getting the style correct.

I think using an example will be the simplest, so I will describe what hapens. When I create a bibliography from Zotero, this is what I get:
Nietzsche, Friedrich. The Will to Power. New York: Vintage, 1968. Print.

First of all, I don't get the translator Walter Kaufmann in the bibliography. According to MLA, it SHOULD look:
Nietzsche, Friedrich. The Will to Power. Trans. Walter Kaufmann. New York: Vintage, 1968.

So as you can see, I also get the unnecessary "Print." stuff at the end of the bibliography I create from Zotero. Is anyone else encountering this issue? I think Chicago style comes closest to what I need but I'm just wondering why the style differs from what I'm accustomed to. Thanks!
  • because you're wrong about how MLA style should look. The "Print" is required.
    I believe this changed end 2008/early 2009.

    (btw - for MLA to work correctly you'll need to have the "include URL" option checked in the styles tab of your Zotero preferences.
  • Thanks! I apologize for not doing the research before posting.

    But do you know why I don't get the translator of a work? That certainly hasn't been changed, as I still see in the link you attached.
  • that might not be implemented in the current style - do you have the translator listed as such in Zotero? Does s/he show using Chicago style?
  • Yes, I do have the translator entered in Zotero, and I see the translator when I create a bibliography with the Chicago style. It's always been like this ever since I began using Zotero over a year ago. It would be nice if this can be fixed.
  • I manually updated the MLA style at <>; but the issue still persists (I've tried the developmental build as well).
Sign In or Register to comment.