rtf scan problem


tried to use RTF scan in an RTF file and it did not work. It does not find the references and the RTF file it generates cannot be open by winword (2007).

tried to scan a simple text file and had the same problem

anybody else with the same problem? any solutions?

  • not enough info here. How did some of those references look?
  • here is the contents of the file (I was trying different citation methods):

    lkjalsdkj laskdjf laksjd lfkasjd lfkjsa ldkf {gosha, 2005}
    gosha {2005}
    laksjdlfk {travis 2001}
    {luton, 2010}
  • are the authors no capitalized in your database?
  • no. I tried to capitalize but it still did not work.

    I get a complete black page in the "verify cited items" windows, on both situations
  • What version of Zotero are you running? Are you able to generate a report ID?
  • version 2.0.9

    report ID: 1536577201
  • Dear Adamsmith and Simon. any idea why RTF scan is not working? did you get any info from the report ID I sent you? thanks
  • Dear Adamsmith and Simon.

    Happy New Year. I still have the error reporter in the beginning of this threat. I tried in different computers (all PCs) and I always get the same error.
    any idea why RTF scan is not working? did you get any info from the report ID I sent you? thanks
  • I've had a similar problem but found a work around. This may not work for you since it seems that your not using google docs. My work flow was as such:

    Process that wouldn't work:
    Created document with google docs including references
    Downloaded as RTF
    Used Zotero "Scan RTF" function, THIS WOULD GENERATE A BLANK PAGE on "verify cited items" page.

    Process that DID work:
    Created document with google docs including references
    Downloaded from google docs as Word document
    Opened in MS Word (2007) and saved as RTF (renamed file)
    Used Zotero "Scan RTF" function, verified references (which were now included on "verify cited items" page.
    Created new RTF file with correct bibliography.

    Interestingly, if I downloaded a document from google as an RTF and opened in MS Word (2007) and re-saved it as an RTF, the process still wouldn't work.

    I don't know much about word processing, etc but this leads me to believe that RTF does not necessarily equal RTF. Thoughts?
  • Update:

    Actually, the process I described above sort of worked for me. There are still a few references scattered throughout my "RTF Scan" output file that did not convert to references but still look like {referece, year}. If I go back into the MS Word (2007) generated file and erase and retype the reference character-for-character and redo the "RTF Scan" then the references properly convert. Weird...
  • I have the problem.
    The workaround by pchaffin works, but in my case the RTF scan stumble when multiple references are grouped e.g. { author A, 2001; Author B, 2007; Author C 2008} with only the last reference being acquired correctly.
    The tool is also somewhat difficult to use when disambiguation is needed, since it is unclear to which instance in the text the request refers to e.g. multiple references with same author names and years but referring to different papers in different places of the document scanned.
  • I also have long been noticing that Google Docs creates rtf files which cannot be immediately scanned by Zotero. The files are formatted as a single line somehow, and maybe there lies the problem (?). The following command line will fix the issue:
    lowriter -convert-to rtf -outdir . input.rtf
    without the need of having to open the Word/Writer program. Also, if you are experiencing unpleasant boxes around your pages when downloading rtf files from Google Docs, the following command line will fix this other issue:
    sed -i 's/\\box//g' input.rtf
  • Where are you entering those command lines? Can you also paste and example of an exact example. Thanks a lot.

    I am extremely eager to use Google Docs the whole way from starting to submitting the very last (really last) version of a manuscript (sometimes to the subsequent journals if at first rejected). I see zotero rtf scan as the only feasible (eventhough crude) way to do it.
  • edited July 20, 2012
    that's a commandline function - it will work in linux and mac from the terminal.
    On those systems, just use it where "input.rtf" is the google doc saved as rtf.
    If you're on windows you can google for and install sed-like functionality, but really you should switch to a decent operating system ;-).
  • Hello,

    I have a problem regarding the RTF Scan function.

    I use version of Zotero standalone, plus the Zotero plug-in on a Firefox 47.0.1, on a OS X 10.9.5. The RTF Scan function is essential for me, because I write in Scrivener, and I use the function in order to insert all the bibliographical information.

    The problem is very simple: when I access the window of the RTF Scan function, I simply can not continue: although I can select between the three options of RTF, ODF (to citations), and ODF (to markers), I can not choose neither an input nor an output file. Clicking the Continue button does not produce results, and the only thing left to do is simply to click the Cancel button.

    This problem emerged all of a sudden. Also, I remarked that Firefox disabled my add-on RTF/ODF Scan for Zotero 1.0.22 developed by Frank Bennett.

    I am reaching out for help! I am about to deliver a scholarly manuscript that I wrote counting on this functionality, and at the moment I can not use it.

  • Thanks adamsmith. I will post my next comment in this other discussion thread.
  • @adamsmith All is good: problem solved. Basically one should use the new plug-in (https://juris-m.github.io/downloads/#auxiliary-plugins) both as Firefox plug-in and as standalone plug-in, the latter to be installed manually. Thanks!
Sign In or Register to comment.