Implications of LibreOffice for OOo Integration

I am wondering if there are any serious implications for future support of the word processor integration, now that the LibreOffice fork has been announced. I installed LibreOffice and successfully installed 3.0a8 merely by changing the paths, which are not automatically detected. Is it likely to be as simple as that?
  • Probably. It is the same code base after all, and I expect maintaining compatibility over time for extensions will be a high priority.

    There's a related thread, though it doesn't say much.
  • Jim, A quick question. How did you "merely" change the path? Does one need to get rid of OpenOffice?

    Thanks, Paul
  • I'm sorry but I left the most important information out of my original post. The extension reported that it had successfully installed after I manually changed the paths to:
    and clicked on the reinstall button, but the extension didn't work, producing an error message in LO that "Openoffice could not communicate with Zotero. Please ensure Firefox is open and try again." I uninstalled the extension in LO and the add-on in Firefox, reinstalled, and got the same error message. So, in answer to your question, there's no "merely" about it.
  • now, libreoffice 3.3 beta3 connect with zotero well on mac.
  • Hello, this seems to be related to my problem, even though I fear I am far from getting the "not merely" even with explanation. What is the problem: I switched from Oo to LibreOffice a while ago, then got Zotero, plugin and all, used it for a while, and in between opened the long-forgotten Oo writer again. I remember that the Zotero-buttons appeared in it. And I guess somehow Oo has "taken over" the plugin - that's as far as I come in my imagination. Thus it seems that I need to redirect it somehow. The result is, namely, that I can't edit or add citation in LibreOffice anymore, just get extension-error messages, whereas everything works in OpenOffice. Or do I have to throw Oo out to avoid conflicts? I'd be very glad about help - if possible please rather simply explained -, you'd really make my day!
  • LR_B, what version of Zotero OpenOffice Integration do you have installed? This shouldn't be a problem in Zotero OpenOffice Integration 3.5a2. If you are up to date, provide a report ID.
  • Had 3.5a2 and, just to make sure, had reinstalled it. To be honest, I tried everything I found on the troubleshooting pages on the matter. Also sent a report. I only have to admit: I copied the ID, then copied something else, and thus lost the ID ... :/ But the notification I got referred to the NullPointerExemption and Java. Since I really needed to go on working, I chose the shortcut, uninstalled Oo, reinstalled the extension, and just made everything work again. But obviously that is not solving a problem, but evading it ...
  • [Nevertheless, thank you very much for replying that quickly!]
Sign In or Register to comment.