Problem with number-of-pages

I have been working on updating a custom 0.8 style to 1.0, adding in some extra elements that are only possible with 1.0 and have got stuck on the number of pages in books.

First of all, my 0.8 style which worked perfectly (showing the number of pages in books) would only validate against the 0.8 scheme if I commented out the 'number-of-pages' section.

Now I have a new style running under 1.0 and adding 'number-of-pages' for books in the right place does not make it show up in the bibliography. The style does validate against the 1.0 scheme, though.

Has anyone had any trouble along those lines? Or succeeded in adding number-of-pages to a 1.0 style?
  • would probably make sense to post the style to so people can have a look.
    btw. - number-of-pages does validate in csl 0.81 - which scheme are you validating against?
  • edited September 22, 2010
    I was validating the old style against csl 0.81, says:

    "Bad value number-of-pages for attribute variable on element label from namespace
    From line 115, column 15; to line 115, column 84
    <label variable="number-of-pages" include-period="true" form="short"/>"

    I have posted the new 1.0 style at
  • number-of-pages is not implemented in the trunk.
  • Right - I installed Zotero 2.1 Beta 1 from the start page - so it's normal then that number-of-pages won't work?
    Any reasons why/estimates when that will be possible?
  • It appears that number-of-pages has not (yet) been implemented in the CSL processor. I'll remedy that within the next few days. Hooking up from the Zotero interface should be easy to do; I'll look at filing a patch once I get the processor going with the variable.

    Thanks for pointing this out -- it's an item that I simply missed.
  • Any news on this? I would really like to be able to use the new style in a training session at the end of the month and numbers-of-pages are rather crucial to our archane citation norms...
  • edited October 6, 2010
    Sorry I needed a nudge to get back to this. My mumblings above about the processor not supporting the variable turned out to be poppycock; if the variable is passed through by Zotero, it formats just fine in the processor.

    I've filed a simple patch, which will likely go in when the developers have time to look at it.
  • cheers, looking forward to that working!
  • Sorry for overlooking this. The patch will be available in 2.1b3. However, your CSL here, doesn't look valid, which is probably why you currently get an error rather than just missing number-of-pages in your output. You need to use <text variable="number-of-pages"> instead of <label>.
  • cheers - have exchanged "label-" for "text variable" and am now sitting tight on my patched version of 2.1b1 and eagerly awaiting 2.1b3.
  • sorry to keep bringing this up, but I have now tried the newest beta(4) and still can't seem to get my style with number-of-pages running.
    More specifically, the style here installs without problems in my patched version of 2.1b1 (as above) and produces the desired output with the number of pages. When I try to install it in b4, I get a message about it not being valid csl - despite the fact that it validates correctly.
    Any insight on this? According to French citation norms we have to include numbers of pages for books, so this is quite important to me and others.
Sign In or Register to comment.