Firefox hanging on startup after 2.0.8 update


After the Zotero 2.0.8 update, Firefox 3.6.9 hangs on startup and has to be force-quitted (I'm on Mac OS X 10.5.8 on PowerPC G4).

Starting Firefox in safe mode and disabling Zotero solves the problem.

I did not have the 2.0.7 problem -- went straight from 2.0.6 to 2.0.8, I think.

  • How long did you let it go?
  • Try generating real-time debug output for the startup, and if anything appears, let us know what the last line is.
  • Actually, you may not see that debug option in about:config in Safe Mode, in which case, once you're in about:config, right-click on the list, New, Boolean, preference name "extensions.zotero.debug.log", and set it to "true".
  • Thanks for the help, the problem is solved. Sorry about the noise.

    The debug output ended with
    "zotero(3): Updating installed translators from"

    Reminded me I had some unsound tweaked versions of the BibTeX.js translator lying around, as well as backups. There may have been an ID conflict, or something.

    Removing those files from the translators directory solved my problem.

    I should have thought of this first, but I'd forgotten about it because Zotero worked fine in the meantime anyway.
Sign In or Register to comment.