Mixed languages (english/german) in my zotero headlines


I have german version of Firefox (3.6.9) and german version of zotero (2.0.8). But the headlines in Zoteros middle window appear in mixed languages wheras the "Infos" in the right window are mostly in german:

"Autor" is "Ersteller" (=german =correct).
"Datum" is "year" (=english) but shoud be "Jahr".
"Signatur" is "Call number" (= completely different meaning!) but should be "Signatur"

All of my colleages have all headlines in German, so it must be available. I tried to uninstall the zotero add-on and re-install but its still the same.
What could be the reason for that? How to come to the german headlines?
  • additional comment:

    I have installed also the Quick Locate Switcher add-on. I'm not sure if the mixed language problem occured in parallel with the quick locate switcher installation. I uninstalled the switcher as well as zotero and reinstalled only zotero but the mixed language problem was still present.
    Any idea?
  • http://www.zotero.org/support/kb/user_interface_language

    It sounds like yours is set to 'de-AT' or 'de-CH' instead of 'de' or 'de-DE'. There are de-AT and de-CH localizations in Zotero that are inferior to de-DE and should probably just be removed.

    Set it to 'de'.
  • Great, it works! Before it was de-DE and I switched to only 'de'.

    Thank you!
  • After restart now the mixed languages are back!
    I checked the language and it still was "de" so I don't know what to do now....
    very curious..
  • I'm not sure why you'd be getting that result, but if you have the German version of Firefox and you want German, that value shouldn't be set to anything. Go to about:config, find general.useragent.locale, right-click, Reset. Then restart Firefox.
  • 'reset' is gray (unavailable). And it is set to 'de'.
    Nethertheless I restarted again, but without impact. Still mixed languages.
  • Have you tried disabling all other extensions?
  • OK, now I have disabled the 'quick locate switcher' even it was also set to 'de' and now after restart of firefox its completely German.
    Later I will restart the complete system for checking.

    Thank you by now!
  • edited September 15, 2010
    Everything works fine after restart with disabled quick locale switcher. The only thing now is that when citing a reference with several authors it appears "u.a." instead of "et al." (its the German translation) even if its an English text.
    But luckily we have our own adapted style where its defined to use "et al.". Only when using the "official" styles I would need to switch back to "en-US" and would risk to have mixed languages in my zotero headlines.
  • No, changing the useragent setting is never the correct way to change Zotero's bibliographic output.


    The setting described there has no effect on the Zotero UI.
  • I was affraid to change it to "en-US" ... may be the mixed headlines would come back. But it looks to work!

    You are great - thank you!

    May be you could also give assistance to another problem of my group?

    Many thanks!
Sign In or Register to comment.