GNU/Linux Insert citation-popup is in the background instead of on top of Writer

I'm running Arch Linux, with kde, firefox and openoffice-base.

When I click Insert citation in Writer, I see a new firefox window appear on the task bar, but have to click it (or alt-tab to it) in order to get it in focus. Does anyone know how to get it on top automatically?
  • I have the same problem using Ubuntu (Karmic). Sometimes it seems to work all right, but sometimes it doesn't. It would be great if there were a solution to this.
  • Hmm, on my system it consistently "pops under". Maybe it is possible to define a special KWin rule to avoid this, but, well, that's a hackā€¦
  • The hack worked! For KDE users who have this problem, do "insert citation", and on the task bar you'll see a popup which doesn't pop up. Click it, then click the tiny "firefox" icon in the upper left, you'll get a drop-down menu. Under "Advanced", select "Special Window Settings". Select the final tab (called "Omvegar" in Norwegian, no idea what it's called in English). Tick off "Prevent focus stealing", select "Force" from the first drop-down and "None" from the last drop-down.

    So what was happening was that the default "Prevent Focus Stealing" setting was too high in KDE, by not preventing Focus Stealing, the window can now pop up above OpenOffice Writer =D
  • Gitty, see if any of this helps:
Sign In or Register to comment.