The Economist ( is no longer recognized

Until recently, I always saw the translator icon whenever I open an article on I could just save any article to Zotero by single-clicking the icon. But I stopped seeing the icon now and I have to manually add the entry, which I would not like to keep on doing if I don't have to. I'm not sure what caused this change. Did Zotero take away the translator? Or could it be the problem with my system? I'm using Ubuntu 10.04 and Firefox 3.6.3.
  • no Zotero didn't take it away - Economist changed the site, the translator doesn't work anymore.
    ticket created:
  • Thank you for your prompt reply. Good to know it's caused by the website and you already filed a bug report.
    Hopefully they will fix this soon!
  • Any progress on this issue?
  • I've made some changes that work for everything but search results. Gist at --- you'll need to save it ( Economist.js) as "The Economist.js" (replacing the existing file) to the translators directory of your Zotero data directory and things will start working again.
  • Sweet!! It took me a while to figure out which translator I needed to replace (as there were bunch of 20xx-xx-xx named translators), but your script surely works! Thank you very much :)
  • Actually, I just realized that the script is not capturing the date of the article (when it was published). Is that something that can be added? Getting the correct date is quite important for me.
  • Fixed now.
  • Brilliant!!! Thank you so much!
  • (as there were bunch of 20xx-xx-xx named translators)
    What do you mean by that? You mean in your translators directory? If so, and if you're using Dropbox or another syncing tool, you're corrupting your data directory.
  • I also found translators renamed in my installation of Zotero 2.1b1:

    I upgraded from Zotero 2.0, but Frank was able to duplicate this with a clean install of 2.1b1.
  • edited October 3, 2010
    Forgot to mention, yeah I'm using 2.1b1 now. I didn't find any "The Economist.js" translator before I downloaded one from this thread. The Economist website was still not recognized even after I downloaded and copied the file into the translators directory, so I basically assumed that there was a duplicate file for the Economist website that's preventing this new "The Economist.js" to take effect. So I started searching for the term "economist" from each script and managed to discover that "2009-01-12 234000.js" was the one for the Economist website (which wasn't working).

    I wouldn't know how things should've been (before 2.1b1), as this was my first time touching a translator. Do you think I can continue working like this? or would you suggest renaming the filename "The Economist.js" (from this thread) to "2009-01-12 234000.js" in the translators directory (just the name, not the files)?
  • OK, this would be me using an outdated version of the build script when I built 2.1b1—it's not a problem in SVN or dev XPI builds. We'll fix it for the next release.

    areteichi: You can safely remove that existing "2009-01-12 234000.js" and just keep the "The Economist.js" file. The filename is irrelevant to Zotero.
  • edited October 3, 2010
    You can continue working without making any further changes-- we haven't figured out yet what's causing this, but it seems to be a bug in the 2.1 betas. It will have to be fixed in a subsequent beta release, and the funny filenames won't actually cause a problem for you.

    [Edit: What Dan said. Nothing like prompt service in these forums, eh?]
  • Thanks for clarification! I'm glad this problem is solved :)
    Looking forward to future improvements and fixes!!
  • The minimal patch has been committed to the SVN ( and should hit clients when Dan pushes it or with a future release of Zotero.

    I will look again at implementing saving from search pages; it is not working in the version I committed, and so I have disabled the icon the address bar accordingly.
  • @ ajlyon

    I'm now experiencing a funny issue. Instead of saving the date of the article, Zotero is capturing the category to which the article belongs in the date field. So I see categories like 'Leaders', 'International', and 'Asia' saved in the date field. I believe this started happening about a week ago.

    Is this caused by the changes made to Economist website?
  • Hi - I'm still experiencing problems with the Economist translator. I saved the link above as suggested over the Economist.js file in my translators directory, and I reset translators and styles in preferences, but it still isn't working. I see the icon but it brings up the error message when I click it. Any thoughts on what I'm doing wrong?
  • edited December 24, 2010
    joycekwc, if you're using Zotero 2.1 beta, did you try deleting the original translator that was in the directory? For me, the file named "2009-01-12 234000.js" was the original Economist translator. Unless you delete it (or move it somewhere else), I believe the new translator won't come into effect. But I think this solution is relevant only if you're using Zotero 2.1 beta.
  • Hi have the same problem as joycekwc.
    The economist.js translator doesn't work.

    Areteichi, I'm using Zotero 2.0.9 with the translator Economist.js. The tranlator you were talking about is not in my folder.

    Does anyone have another solution??

    Thanks, Erez
  • I'm using 2.0.9. There is a "The Economist.JS" in my translators folder. When I am reading an article on The Economist and click on the little newspaper icon, I get a "Could not save item" error. Should I upgrade to 2.1?

  • no. the translator is broken in general.
  • I'm working on this again.
  • At least the translator in 2.1 betas was working fine for me on the Economist website with Firefox 4 beta, but that was until I upgraded to Firefox 4 beta 11 last night. Although it still seems to be able to save some articles, I'm now getting errors with FF 4b11 saving some other ones like these for instance:

    I know I could save them on Zotero 2.1 beta 5 with FF 4b10, but I'm now getting errors for some reason on the newest FF beta. Yet I can still save some articles even on FF 4b11 like this one:
  • Ok this issue seems to be resolved in Beta 6 :)
    Thanks to all the developers!!!
Sign In or Register to comment.