Create Bibliography from Selected Items won't work with MLA

When I try to Create Bibliography from Selected Items, I can't select Modern Language Association as a citation format. The format is present in the menu, but, unlike every other choice, it refuses to respond.

This looks like a bug to me -- or am I doing something wrong?

I'm using Zotero 1.0.0rc3 on Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061201 Firefox/ (Ubuntu-feisty).
  • Hi,
    Which kind of output are you choosing - Save as RTF, Save as HTML, Copy to clipboard, or Print?

    Also, could you explain more what you mean by "refuses to respond"?

  • Hi,

    I've just managed to fix the problem completely by accident.

    Regardless of output format, I couldn't select MLA: all other options in the list were selectable by left-clicking them, but MLA wasn't (or anyway, didn't get a coloured background bar to indicate 'selected' status).

    In the Preferences, the default _wasn't_ set to MLA, but as it turned out, Create Bibliography from Selected Items formatted entries as MLA anyway, even if the format couldn't be selected from the menu.

    Once I created a reference in a format other than MLA, MLA became selectable again, so all seems to be well now.

    Thanks for asking the right question. =)
  • edited January 11, 2008
    This selection problem with off-screen styles (so, generally speaking, styles towards the end of the alphabet) should now be fixed in the latest dev build. If you're using a dev build, give it a try and make sure it works on your system in both the Create Bibliography and Word/OOo doc prefs windows.
  • I have tried this. I had mine set in preferences as MLA to begin with & it still gave me an error message when I tried to export it. I also saved it first to APA and then switch it, which it let me do, however when tried to export it it still gave me the error message. I also tried the link to download the fix but it wouldn't download anything. I clicked & nothing happened. Any other suggestions?
Sign In or Register to comment.