New Keyboard Shortcut for 'short citations'

Since many of the issues around the use of the Chicago styles with Quick Copyhave been nicely addressed on the development version. This thread is now mostly old news. But I wanted to pick one bit out of that mire to re-raise on a fresh thread. It is mentioned briefly at the bottom of ticket 734, but I didn't want to burden the ticket itself with discussion.

It would be really nice to have (yet) another quick copy command in Zotero which would produce a formatted foot/end note with 'short citations' of the kind used after the initial citation. As it is now (if you want to format according to Chicago style with long initial footnotes) when you cite an item more than once, you have to either manually remove the publisher, place and date, and shorten the title, OR you have to switch to "CMS w/biblio" in the preferences, then switch back again. Both of these are a lot of work.

An accompanying context menu might also be a good addition. Note that this basically amounts to retaining the current "CMS without bibliography" style as default, but then copying a single note in "CMS with bibliography."
  • Seconded. In my work, we have the following:

    - Full info on first reference
    - Short info on subsequent references
    - Full Bibliography

    So I want a style "with bibliography", but that also makes it possible to get full info. Something like Ctrl-C (why is it Ctrl-Alt-C - what's wrong with Ctrl-C?) for copying one, and Ctrl-Shift-C for copying the other.
  • I'm uneasy with this idea. I'd prefer if Zotero automatically rendered the correct form depending on the position. Wouldn't that be a better solution than adding some new key-combo? Citation formatting should, after all, be as automated as possible.
  • Well, right now it's not automated for people who want CMS long citations and bibliography in the same document. The choices should be "Chicago with bibliography & short citations only" and "Chicago with bibliography" (which would include long & short citations) and "Chicago without bibliography."
  • edited October 4, 2007
    A clarification: The original suggestion was for an expansion of Zotero's internal quick-copy only (not for use with word processor plugins, which should certainly automate the difference). It would be a way of allowing easy citation-insertion using styles like CMS/notes with "first citation/subsequent citation" patterns when not using a WP plugin. This is mainly valuable for those using a non-supported WP/text editor or for people who choose to use quick copy for other reasons (they need more flexibility in how their citations actually look than the Word/OOo plugins currently provide). So far, I'm in the last category, but I may soon be able to jump ship.

    It's true that we need a Chicago Style with both long initial citations and bibliography, as discussed in the last three comments here. Which should be easy enough to cobble together from 'CMS w/o bib' and 'CMS w/bib' when the new Chicago CSL Styles are ready (which perhaps they are). If gerv is using the Word/OOo plugin, this would answer his and Elena's needs as well--and mine when I make the jump to the plugin.

    Bruce: this does bring up another CSL question for me.
    I've started a new thread for it. Basically: Would it make sense to find a way so that common variations in style output could be handled without forking a CSL style, but by user-specifiable options within the style itself?
  • Was there ever an update to this? I would really appreciate it to be able to quick copy 'short citations' of the kind used after the initial citation.
  • Not really. It's automatic using the word processor add-on, obviously. You can set up quick copy for the Chicago Note style, which always renders the short version. The Zutilo add-on lets you add multiple quick copy options available at the same time, so that could be used to have similar results.
  • Thank you for your reply, Zutilo seems like a fix here, but one issue remains:

    Zutilo's quick copy alternatives all do a "normal" quick copy which seems to be formatted in the style of a bibliography (starting with "1." and automatically using Times New Roman). As I assume this is something dictated by Zotero (as this is also the vanilla quick copy behavior), is there any way to change this default behaviors?

    I don't need to quickly copy bibliographies, I need to quickly copy citations, so ideally all output would be in the style of Ctrl + Shift + A copy-pastes from the start.
  • I was pretty sure you could get Zutilo to quick copy a citation, but don't have it running right now (you should never get numbers for a Chicago style, though, and Zotero doesn't specify the font)
  • edited September 11, 2023
    Thanks for the reply. I'm using a custom citation style and my style doesn't even define a bibliography style, so is the numbering just default behaviour per chance? Additionally, any idea why it seems to always use Times New Roman (which it does not do for citation quick-copies)? Could this be related to some Word style settings?

    Edit: I found parts of my answer here:

    Going to File -> Options -> Advanced -> General (section) -> Web Options... -> Fonts and changing the Proportional Font fixes the Times New Roman issue. The numbering issue remains
  • @adamsmith, any idea why Chicago style does return numbers, but my custom style does? I'm not aware of having set it to do so anywhere.
  • @adamsmith I managed to fix this as well by just providing a bibliography style that basically corresponds to the citation style - dirty but works. One last thing though: When pasting, the formatting in the paragraph the reference is pasted into is messed up and the cursor comes to rest at the subsequent line. Is there any way to affect this behaviour?
  • I don't know -- the bibliography has a bunch of formatting commands (like hanging-indent="true", entry-spacing, etc.) that likely do this. You could try playing with them, but not sure how far you'd get.

    I don't know where the numbering comes from when using create bibliography on a style that only has citaitons -- that seems odd behavior, tbh. I'll see if I can reproduce and if so, might be a bug
Sign In or Register to comment.