Retrieve metadata: a different problem (I think)

Most problems with Retrieve Metadata seem to involve the process hanging. My problem is that the process completes but almost never finds a reference. for example, I had a PDF of the following article, which is a mainstream management article easily found in Google Scholar:

Kirca, A. H., S. Jayachandran, and W. O. Bearden. 2005. Market orientation: a meta-analytic review and assessment of its antecedents and impact on performance. Journal of Marketing 69, no. 2: 24-41.

The Retrieve Metadata process spun for about five seconds and then said that no matching references could be found. This happens almost every time, which makes the process worse than useless. Am I doing something wrong?
    this works for me - can you confirm it's not working for you?
  • Confirmed: it does not work for me -- "No matching references found."
  • if you select the pdf - does it show up as indexed? (on the right hand pane - Indexed: Yes)
    Is there anything particular about your internet connection? A strict firewall or so?
  • I figured it out! -- your question about the internet connection got me thinking. It's not a firewall, but I access Google Scholar through a proxy at Rutgers University, which then shows the Rutgers holdings and lets me get them immediately. But it signs off very rapidly. What seems to have happened is that I was signed off the proxy when I tried to retrieve metadata, and I guess Zotero just went my usual route but didn't pop up a signin screen. When I signed in to the proxy (on a separate screen) and immediately ran the Retrieve Metadata, it worked.

    I appreciate your help. I wonder why the signin screen doesn't pop up when accessing from Zotero, as happens when I go to Google Scholar myself?
  • The sign-in screen won't show because Zotero is accessing Google Scholar in a hidden browser.

    I don't know much about the proxy support in Zotero, but it may be possible for Zotero to log you in to the proxy automatically, so that Retrieve Metadata will work as anticipated. Otherwise, you will have to disable proxying while you retrieve metadata. Hopefully someone with more proxy experience can advise you on how to set up your proxy to be Zotero-friendly.
Sign In or Register to comment.