Runtime Error 5, again

I am sorry if I missed any discussions about this. I have thoroughly searched this forum, and have searched google as well for other users with this problem. None seemed to fit.

I am getting this error when trying to insert a citation:

Run-time error '5':
Invalid procedure call or argument

* I am running the latest version of zotero (2.0.3)
* I installed the word add-on v 3.0a3
* The tool bar shows in word
* I tested to see if the error persists in a new document or in an existing one with already added field codes (from my other machines). The error is indifferent to file type.

To remedy this, I have tried the following:

* Made sure I was running the latest Zotero
* Uninstalled the Word add-in in Firefox
* Found and deleted
* Rebooted machine
* Reinstalled the Word integration into Firefox
* Ensured that the toolbar shows in Winword

And I got the same error, again.

Anyone have a fix? It might be relevant that I just installed Win7 32bit. Before this I had no problems.

Thanks for any help. I'd hate to have to give up on Zotero, but I really need this to work fully.
  • All,

    Sorry to waste anyone's time. Here was the problem, in case this happens to anyone else. For some reason Firefox was running in Windows XP compatibility mode under Windows 7. Once I turned off compatibility mode for Firefox, I didn't get the annoying User Access Control (UAC) intervention when ffox started, and Zotero works just fine. I hope this is useful to anyone who may have this problem in the future.
  • I had the same exact issues as birkland, but apparently a different cause. Upgrading to Firefox 3.6 resulted in UAC as well from running as administrator. Both the shortcut and the firefox.exe had to be modified to make sure I wasn't running as admin. Annoying from Mozilla that this was somehow the default.
  • Hey, I have the same problem, birkland, how do you turn off the compatibility mode for firefox?
  • I'm using Zotero3.0b3 and Word for Mac 2011 on Mac OS X Lion and have the same problem.
    Zotero Word for Mac Integration 3.1.9
    PythonExt 111009

    Runtime Error '5',
    Invalid procedure call or argument

    However, I can use LibreOffice.integration 3.5b3 on the same Mac.
  • Zotero 3.0.1 still showed the same error on my Mac (OS X Lion).

    Runtime Error '5',
    Invalid procedure call or argument

    Zotero Word for Mac Integration 3.1.10
    PythonExt 111220
  • Interestingly, the Zotero Word for Mac plugin worked in another virginal user account in my Mac. It seems that the problem is about my account only. But what's the problem? Any ideas?
  • Try opening ~/Library/Preferences/Microsoft (in Finder, using Go->Go to Folder) and moving the Office 2011 folder somewhere else.
  • Thank you for the suggestion. I tried it, but didn't work.

    I also tried deleting the following, but didn't work either.

    I still have Runtime Error 5. Mmmm...
  • With Zotero 3.0.8, the Word plugin finally worked on my Mac for Office 2011!
Sign In or Register to comment.