Z not retriving PDFs of articles from Palgrave

Palgrave MacMillan have made all of their journals free for May!! Woohoooo!! Get dowloading ladies and gents....

However, Z presently fails to add PDFs to items which are downloaded. I have tried this here: http://www.palgrave-journals.com/ip/journal/v46/n6/index.html
and more randomly, here: http://www.palgrave-journals.com/fr/journal/v94/n1/index.html

It would be wonderful to have this fixed - IN MAY - to take advantage. Otherwise there is the painful task of manually dragging PDF links to items and then that damn interminable wait while Z indexes the file and firefox hangs, until you can do the next one. Hardly worth the effort then!!!!!!!!

Otherwise (grumble grumble) love Z.
  • This problem still has not been fixed with Palgrave MacMillan, and the problem with Cambridge University Press Journals still exists as well - neither are attaching or downloading PDF files to items.

    Is there any intention to work on these?
  • The problem here is that the Palgrave MacMillan site is not being translated by a "site translator"; Zotero is detecting the DOIs (article identifiers) on the page, then pulling data from the service CrossRef. Unfortunately, Zotero has no way of knowing that it can get the PDF from the Palgrave MacMillan site, since CrossRef doesn't tell it that. It would be possible to create a specific translator for PM, but it's a lot of work for little benefit.

    Separately, Firefox shouldn't really be hanging too badly when you attach items. Does that happen every time? What operating system?
  • Thanks. Pity about that.

    The hanging seems to be related to indexing the pdfs. I run firefox on macbookpro, latest releases of firefox and zotero.

    Any news on the Cambridge Journals site?
  • Can you give me a URL for Cambridge journals? The one I came up with was something that UCLA didn't have free access to anyway, and I didn't want to pay 25 pounds to diagnose a bug!
  • This is the URL I use:

    except it comes complete with my library's proxy server in it. so, delete after".org" in the URL. If you do that you should get to the home page, which will have a link to the complete list of journals. The journal I was downloading from was Review of International Studies. If UCLA doesn't subscribe to that,t hen I'm sure there would be others on the list that are subscribed. I imagine the problem is systemic.

    - yes, apparently, having just randomly tried to download from another journal. It downloads the item, attaches a file, but when you go to view the file you come up with a dialog box that says, among other things,

    "download php is a scrip application...."

    and then opens it in a text editor as a random lot of - well, script (at least to the uninitiated!!).

    many thanks

  • Sorry-- I just tried to fix the bug, and it's not that easy. The PDF fulltext link brings you to another page, which should have the real URL for the PDF, but I can't get Zotero to save that URL correctly. My suspicion is that Cambridge is checking for a referrer or cookie or something, but I can't get it to work. For now, you'll need to drag manually.
  • Many thanks for the effort. I shall grin and bear it until you guys are able to work your miracles!! ;-)
Sign In or Register to comment.