Syncing: file cannot be updated

When I try and sync I get the following error message.

The file 'McKenna, 1995, The origins of modern management consult.pdf' cannot be updated. Check that the file is not currently in use and that it is not marked read-only.

Restarting your computer or disabling security software may also help.

I've tried the suggestions (rebooting, etc) and the problem remains. I've deleted the file (I tried both the normal delete and by going to the folder and deleting it there), and the problem remains.

Any ideas what else I might try?
  • If you actually deleted the file it's unlikely that you would get that message. Are you sure there's not more than one copy of it in your storage folder?

    You shouldn't need to delete it, though—it's far more likely that it's just marked as Read Only.
  • Hi Dan,

    Thanks for the suggestion. Searching (using Zotero) didn't reveal any other copy of the file. However, using the OS to search the storage folder found four other copies. I deleted those, added back the PDF to the Zotero entry.

    The synchronisation process is now merrily running (I would have normally had the error by now).

    Thanks (yet again) for your help.

    Running a 'dup checker' over the storage folder shows a few other anomalies. Out of 933 PDFs, there are 188 duplicates. I wonder how the orphaned copies came about.

    Is there a tool to tidy this up? Otherwise, I'll do it by hand.
  • They're not necessarily orphaned. Do you use group libraries?
  • Why yes I do. So, perhaps (having fixed McKenna) I should leave the rest (of the 'orphans) alone?

    (I note a few of the files have different names from one another ... and sometimes not. I'm checking on their CRC).
  • Emptying the trash has tidied up all the duplicate files with different file names.
  • I have the same problem now.It doesn't work even I cleaned my trash.And further, I delete that specific file and zotero pops out that another file has the same problem....
  • Yichao: Restart your computer, check file permissions in the Zotero data directory, and/or try disabling security software. No other answer for you.
Sign In or Register to comment.