Help pls. Moved items to a Group folder and deleted. Now need to undo...

Hi. I just moved about 20 items from one Group folder to another.
Then I deleted the items from the original folder.
I thought I had checked to see that the move worked before deleting.

But when I went into the folder, it's empty.
I tried to stop sync via preferences, but the changes already show up in Zotero webside.

Is there a way for me to recover what was deleted from the Group folder?
(The items don't show up in my (personal) library collection's Trash.

  • Same thing happened to me--appeared as if items had "copied" rather than "moved." I deleted the items from the source folder and they disappeared from both.

    In my case, however, they DO still show up in my Trash folder, yet I see no option for restoring what's there.

    Can anyone help?
  • You can restore individual items from the trash. Click on one, then in the right pane at the very top will be an option to restore the item to your library (I think it should really be a context menu option).
  • Than you very much. I did find that in the meantime and I agree with you on the context sensitivity.
  • edited August 17, 2011
    I'm having a similar problem: I deleted something from a collection in a group library, but didn't realize it deleted the main reference also. The library synced already, so I can't find it online or in my personal library trash. Is there any way to recover it?

    UPDATE: I managed to recreate the item & note by looking in Recently Created, but I was worried there for a minute. Why is there no Trash Can for group libraries?
  • wagerlau: You might want to review Collections. Removing items from a collection doesn't delete the items from the library in either the personal library or a group library—the items would've just been in the root of the group library unless you actually selecting "Deleted Selected Items from Library" from the context menu. Undo functionality would help for restoring items removed from a collection, but not a trash can.
  • In fact, I didn't select anything from the context library. I pressed DELETE while viewing the item in the collection, which I thought would delete it only from the collection. There was no warning message, and it was gone. But I have learned my lesson, and now I Remove via the context menu.
  • Sorry, but pressing Delete in a collection does not and has never deleted items. It just doesn't work that way.
  • Sorry, but it deleted mine. And yes, i'm absolutely certain i was looking at the item in the collection in my group library.
  • Then reproduce it, and I'll acknowledge and fix the bug. Unless you can, there's absolutely no reason to believe that Zotero is functioning for you differently from the way it works for everyone else.

    The only exception to the above is Ctrl-Delete (Cmd-Delete on Macs), which turns a collection removal into an actual delete. But then it also displays a confirmation dialog.
  • Hi there

    I'm having a similar problem. I accidentally created a reference in the wrong folder. I've tried a few things to sort this out, but I've become stuck.

    I have duplicated the entry, then moved it (the duplicate) to the folder I want it to be in and then deleted the entry from the folder I don't want it to be in, but this deletes it from both folders. But I can't seem to move it without duplicating.

    Can anyone help? Many thanks.
  • Ha, typical .... sorted it. Was a case of confusion between "remove selected" and "remove selected from library."
Sign In or Register to comment.