In-text citations have unlinked from the Bibliography

I have a very long document with many citations, and at one point, the auto-refresh was taking too long and Zotero told me to turn it off and manually refresh. This was working well, but now I'm in a situation where there are a couple of duplicate references in my document that are slightly different from each other (eg. author name order, having/not having a DOI number). I checked my library, and these duplicates have been deleted, but they still exist in my document.

I've gotten rid of the in-text citations for these duplicates (and retained the ones in my Zotero library). However, the duplicates are still in my bibliography. I've tried toggling the hidden fields, but I don't see them there either.

I've also tried deleting the area where the reference would've been, re-writing it, and re-adding the citations, but when I click refresh, the bibliography looks the same (still with duplicates). I've come to the conclusion that the in-text citations are just not linked to the bibliography anymore, but I need them to be.

I've tried literally everything:
- refreshing Zotero, restarting my computer
- changing the bibliography style and changing it back
- searching for hidden fields
- manually changing the bibliography (doesn't change the in-text citation numbers)

so any help on this would be much appreciated!
  • When you change the citation style, do your citations actually change? Can you edit them if you click in them and click Add/Edit Citation? You want to make sure that all citations in the document haven't become flattened.

    It would be odd for just the bibliography to become flattened, but if that's the case, you can just delete it and re-insert it.
  • They did change and I can edit them in add/edit citation. I've also tried deleting the bibliography and re-inserting it, but the duplicates remain even after re-inserting.

    I also did a test by adding a new citation, deleting it, and refreshing the bibliography, and the new (now deleted) citation still shows up.
  • For future reference, you'll want to merge instead of deleting duplicates in your library. Deleting a duplicate leaves the duplicated reference in the document, now disconnected from a metadata entry in Zotero, instead using data stored in Word by Zotero when they were originally inserted.

    If you click on "Add/Edit Bibliography" do you have the option to Revert all? If so, click it (it might be greyed out).
    If that doesn't work, best bet would be to switch to a numeric citation style and identify the duplicates by number.
  • I did merge them, but the duplicates are very slightly different, so I'm not sure if that's why they stayed in the document even when they were merged in my library.

    Also, I don't have the option to revert all. The bibliography was already numbered, so I do know the numbers of them. However, even if I delete them from the bibliography manually and change the numbers in add/edit bib (so that there's no skipped numbers), the in-text citations don't refresh to match the new numbers
Sign In or Register to comment.