Citing in Word with Zotero 7

I have been using Zotero 7 with any problem for the last several months. Yesterday, when I tried to insert a reference in Word I got the message that "Word could not communicate with Zotero..." I deletet and re-installed the *.dotm file in Add-ins but it did not work. Does anyone have any suggestions? Thanks.
  • It would be helpful for you to report your operating system and Word version.
  • I have the same problem. I've also reinstalled the word plugin, and restarted both (and the PC).
    Oddly, if you switch briefly to the Zotero interface, and then back to Word and try again, it does seem to load.

    I'm using :
    - Word 2019 Professional Plus 64 bit
    - Zotero 7.0.0-beta.83+066eda731 64 bit
  • The only thing I haven't tried is disabling security (because I'd have to check how on a managed machine), it's also intermittent as described which seems inconsistent with the troubleshooting
  • Same issue here, never had a problem like this before. I'm using the latest beta on Windows 11 and Office Professional Plus 2021.
  • edited 18 days ago
    @sjgknight @epeva what is the full version number of Word and Windows that you are running? Are you running any proprietary security software?
  • @adomasven
    Microsoft Office LTSC Professional Plus 2021 Version 2108 (Build 14332.20685)
    Windows 11 Pro 22H2 Build 22621.3593

    No proprietary security sofware.

    If I restart zotero and word, I can add/edit citations once (or for a bit of time). After that, I get the communication problem.
  • Does it work consistently with Zotero 6?
  • I don't keep Zotero 6 anymore. Any way of trying zotero 6 without altering zotero 7 addons and conf? I have tried it before and it removed my zotero 7 addons...
  • @epeva @sjgknight Once it starts working, does it stop working before restarting Zotero? Does refocusing the Zotero window make it work again? Or does it only break after a fresh restart?
  • I just turned on my computer, there was an update for Zotero, and now the citing feature is working again. Thanks very much.
    I used EndNote possibly for two decades. My library was getting bigger and bigger and finally it exceeded the five GB limit of EndNote. I switched to Zotero about two years ago, my library is more than six GB now and I have no problem. Zotero is a wonderful piece of software.
  • @br_roy, @epeva, @sjgknight: Do you also use Firefox on this computer?
  • Yes, I am using Firefox. I also initially thought that the problem was completely solved but now I realize that I need to go back and forth between Word and Zotero to keep this function working.
  • Similar/same problem here -- haven't quite figured out what makes it break again, but it has repeatedly over the last days -- also running Firefox as my main browser. I'm happy to help troubleshoot as needed.

    For adomasven's questions: Refocussing the Zotero Window doesn't appear to fix anything, no, only restart.

  • edited 14 days ago
    I’v been experiencing the same problem: After using Firefox, when I return to Word it can’t communicate with Zotero. But in my case, refocussing the Zotero window does make it work again.

    FF version: 115.11.0esr
    Zotero: 7.0.0-beta.86 (was the same with beta 81, too)
    Word 365 MSO (Version 2403 Build 16.0.17425.20236) 64 Bit
  • @br_roy @sjgknight @epeva @adamsmith @gduffner This should now be fixed in the latest version of the beta. You might need to manually reinstall the Word plugin from Zotero preferences if you have Word open when restarting Zotero after an update. The issue occurred when focusing a Firefox window, then switching to Word and attempting to cite with Zotero. Refocusing Zotero, then going to Word would fix it (if you didn't focus Firefox in between Zotero and Word). It should now always work. Please test and let us know if you are still seeing this issue.
  • I am now getting this error:
    https://s3.amazonaws.com/zotero.org/images/forums/u265723/gdq5xz4gn13cizu5bavg.png

    So I cannot get it to work at all now.
    I have tried deleting Zotero.dotm and reinstalling the plugin.

    Same as reported here:
    https://forums.zotero.org/discussion/comment/465397/#Comment_465397

    Zotero 7.0.0-beta.86+569225897 (64-bit)
    Windows 10
  • @mjthoraval: Should be fixed in beta 87
  • Thank you, working nicely in beta 87.
  • Beta 87 was only available today for me. But it works fine now after reinstalling the plugin. Thanks!
Sign In or Register to comment.