OpenOffice Portable and extensions

It appears that Python has been removed from OpenOffice Portable ( so that the OpenOffice extension can not be installed. Any plans to accommodate OpenOffice Portable?
  • edited August 23, 2007
    I think it's more that the Portable version of OOo would need to change in order to accommodate Zotero and other extensions.

    In order to reduce the size of OOo so that it can better fit on a USB drive, certain aspects of its functionality have been removed in the Portable Apps version. I believe that, in particular, the removal of the "UNO-Python bridge" is the problem for Zotero users. Without that component, I believe it is impossible for Zotero to communicate with OOo.

    Maybe the developers of OOo Portable will add the missing components back to their build if Zotero users ask them nicely. :) It's quite possible that there hasn't been a strong demand or any other reason to include the needed components in the Portable build before now.

    Apparently, there is a German version of OOo that includes Python (and the UNO-Python bridge, I suppose, I don't know). See:
    Maybe as a workaround you could try installing that and then changing the interface language to English or whatever other language you prefer? There are instructions for how to add an interface language to an existing installation of OOo here:
    I haven't tried this myself.
  • Just to let you know I found a work around.

    1) Download the full version of OpenOffice (or any version that includes Python)

    2) Extract to a temporary location

    3) Copy the folder called "python-core-2.3.4" (or similar, found in [temporarylocation]\openoffice\program) to [YourOpenOfficePortable Directory]\App\openoffice\program

    4) In the same folder you found "python-core-2.3.4" also copy the following files to [YourOpenOfficePortable Directory]\App\openoffice\program

    5) In OpenOffice Portable, install/enable the zotero.oxt extension through Tools|Extension Manager

    The list of file is from memory, in fact what I did was to search for any files called *.py, *.pyc, or py*.* in the [temporarylocation]\openoffice\program folder (exclude anything found in subfolders)
    Also some of the files may not be strictly necessary, but I don't have the time to fully test this

    Hope this helps.
  • This worked perfectly for me.
  • Also worked for me, thanks! Could this get posted as some sort of "howto"?
  • I just updated all of my portable apps and I am happy to report that all required python files are now included in the most recent version of OpenOffice portable. The only thing I had to add to my "program" folder within the OpenOffice Portable directory tree was a copy of python.exe, even though it is already located in another folder within the OOo Portable parent directory. Once I did, Zotero installed without any trouble at all. Youpi !
  • Just in case others have this problem with the OpenOffice app for SanDisk Cruzer U3 drives downloaded from SanDisk Version - just adding these files will not work. It will still say Packet Manger and shut down when you try to install the Zotero extension. You have to uninstall that version of OpenOffice, download the OpenOffice portable (2.4) to your desktop, install it onto your U3 drive by clicking on the downloaded exe file (NOT using the "add programs" feature on the cruzer application). I didn't have to move any files.

    Open OpenOffice, add the Zotero extension, restart OpenOffice and your Zotero toolbar should be there.

    The thing is, if you use the cruzer icon to run programs OpenOffice won't show up there because you install it outside the cruzer app.
  • You could also try something like Open Office Anywhere which lets you run the suite of programs without install on the local computer
  • "The thing is, if you use the cruzer icon to run programs OpenOffice won't show up there"because you install it outside the cruzer app."

    You can easily solve this by creating a short-cut in the LaunchPad with ShortCut Creator.
    Worked like charm for me.
  • Sorry guys. I did install recently the OpenOffice 3.2 portable at c:\openofficeportable; the Brazilian Portuguese version, which so far I dont see as a problem. Im having erros when I isntall the zotero OpenOffice extension. I read the stuff above, the official documentation about the trouble shooting and it just does not work. The error comes: "Zotero OpenOffice Integration could not complete installation because an error occurred. Please ensure that OpenOffice is closed, and then restart Firefox."

    Any help like a step by step procedure?
  • What are your paths in Tools->Add-ons->Extensions->Zotero OpenOffice Integration->Preferences? If you don't have installed in a standard location, Zotero won't necessarily recognize it automatically, so you need to make sure that these are correct. Assuming you have only Portable installed, clicking "Detect Paths" and selecting the path to portable may be sufficient. You also need to make sure that Java is installed; while it's included in the default install, I'm not sure if it's included with Portable or not.
  • Also, if these steps don't help, we will need you to provide a report ID.
  • Simon,

    I checked the path and they are both like this even after the auto detection script:


    Also I checked into openoffice java directory C:\OpenOfficePortable\App\Java and there is a readme.txt file in there with the following content.

    Java binaries go here or in X:\PortableApps\CommonFiles\Java for shared use.

    To enable Java, copy the Java files from a local install, usually C:\Program Files\Java\jre1.5.0_11,
    to this directory. Copy the whole structure intact (so you'd have a lib and a bin directory in this
    Java directory when complete.

    Then, create a text file called javaportable.ini in the same directory as this readme.txt with the
    following in it (altering for Java version):

    Vendor=Sun Microsystems Inc.

    I looked around and found a jre1.6.0_07 directory, but it seems to me that it is a browser plugin for JAVA and not java virtual machine itself. Thus, so far, my guess is that my problem is the absence of java virtual machine. I asked IT to come at my workstation and check this for me.

    I will send more feedback as soon as possible.
  • I got the same problem today with the same Windows settings and Open Office Portable 3.1.1. Every time I started Firefox the same error message popped up.
    After adding the file javaportable.ini as described above and changing the soffice path to
    file:///P:/OpenOfficePortable/App/openoffice/program/ I got the following message:
    Adding Zotero Extension, and now it seems to work.
  • edited February 7, 2011
    the only thing I needed to do is changing the paths to:
    for soffice: file:///E:/OpenOfficePortable/App/openoffice/program/
    for JAVA: file:///E:/OpenOfficePortable/App/openoffice/URE/java/
    and it worked.
Sign In or Register to comment.