Zotero Connector not working with ACM Digital library

As of today the Zotero Connector extension will no longer save papers from the ACM digital library correctly. I now only get website snapshots instead of PDFs.

Yesterday everything worked fine, but today the Zotero Connector won't accept any papers from the ACM digital library. I did not install any updates or similar.
I do have access to the papers and the PDF.

I have already tried:
- Restarting my system as well as Zotero
- Reinstalling the Connector Plugin

An example link would be:
https://dl.acm.org/doi/10.1145/3567739
But as I said, as far as I can tell this is the case for all papers in the ACM digital library.
  • Works for me. Could we get a debug ID from the Zotero connector for a failed save from that URL?
    https://www.zotero.org/support/debug_output
  • I cannot submit the output. I only get the "an error occured" message.
    I did since posting this also try a different browser (Firefox) which works fine, so it seems to be a browser related issue.
    I am currently using the Brave Browser which is chromium based.

    Thank you for the quick answer!
  • If you can't even submit Debug, that suggests Brave might be constraining what add-ons are allowed to do to an extent that Zotero doesn't work. It's not officially supported so I don't think there's any troubleshooting guidance, but you could see if there's any sandboxing preference for add-ons or so. Pretty sure Chromium isn't the issue here. I'd be surprised if Edge and Chrome wouldn't work.
  • That might be. Still wierd that it worked yesterday and suddendly doesn't anymore.
    I am pretty sure that the Add-On has all priveleges it needs.
    Maybe I will mess around with it further at some point and post an update here if I fix it.

    Until then, thank you for your help :)
  • edited 21 days ago
    This is failing for me in Chrome. We'll investigate. We rolled out a major update to the Chrome extension yesterday for MV3 compatibility, so it's almost certainly related to that. Edge still works.

    The error submitting debug output is a known issue that's been fixed for the next update.

    (But @Phlipinator, please don't post here about an unsupported browser without disclosing that. Something being based on Chromium doesn't matter — we support the browsers we support. You should always test on a supported browser before posting.)
  • edited 14 days ago
    @dstillman I use Chrome, and it doesn't work for me either. Just wanted to let you know. It saves papers as a webpage instead of a journal article and doesn't fill in the Author, Date, and Abstract boxes.
  • @dinasaurus_molnar It works for me on Chrome with the newest codebase. See Troubleshooting Issues with Zotero Translators
  • Thanks after restarting both Chrome and Zotero, it's now resolved.
Sign In or Register to comment.