Zotero 7 beta: zotero:// links not working

This discussion was created from comments split from: Available for beta testing: Customizable item pane header.
  • edited 28 days ago
    Any specific reason why Zotero 7 Beta is still not final release? Are many more new features still coming?

    I have been using Zotero 7 for a while now with no real issues. I love the implementation of open tab search, dark theme, annotation on webpage snapshots.

    The only feature I really miss is to be able to link to a specific item in my Zotero library from an external program (e.g. OneNote). The zotero:// function seems to not work, it just opens Zotero but does not search or retrieve the item in the Library. It seems all extensions that allow this are not compatible yet. For now I just copy the unique 'key' value from the local file path.
  • I'm using the Zotero 7 Beta (Mac) as well and this works for me with the Action Tags plugin. See here: https://github.com/windingwind/zotero-actions-tags

    The result for a txt link is: zotero://open-pdf/library/items/[KeyValue]

  • edited 26 days ago
    @darrylmy

    I tried this plugin (Release 1.0.0-beta.39) and it works to retrieve the item link

    zotero://select/library/items/DQK7EP9J

    It works fine with zotero://select, highlighting the item in my Library, but not with zotero://open-pdf (it just switches to Zotero window).
  • @filipesb90

    Glad you got that part to work. Be sure that you are getting the link to the PDF itself (it has the same key value as the folder the PDF is in [if you store your PDFs in Zotero]). If you just get the link for the bib entry, then it will only take you to the bib entry. But if you copy the link to the PDF then the PDF will open in the default PDF reader you have set. Hope that helps.
  • @filipesb90

    Actually, correction: as long as you change the linkAction from "select " to "open-pdf" in the script it will properly copy the correct key value even from the bib entry. So even better!
  • I can confirm links like zotero://select/library/items/ stopped working in Zotero 7 (in today's 88 build as well).

    They worked before in Zotero 6 without any additional plugins.

    When clicking on the link:

    - Expected behavior: Zotero application comes to the foreground and corresponding item is selected in the library
    - Actual behavior: Zotero application comes to the foreground, nothing is changed in item selection

    It doesn't look like an intentional removal of functionality since we still have test for it [1]

    [1] https://github.com/zotero/zotero/blob/137a1ddcc04f42d1b88701462b4cb80c07a61055/test/tests/protocolHandlerTest.js

    I will check in code if I can find the bug that prevents the selection
  • Actually, just checked and local build (from source) opens links as expected, while beta 88 doesn't.

    Both running from commit 137a1dd

    OS: macOS 14.5
Sign In or Register to comment.