Problem report 396602277

Hi
I tried to install the LibreOffice Add-on for LibreOffice in my Apple from Zotero / Cite but I always end up with an error message. So far I have always used Zotero only as a Library and I spent all my Ph.D years copying-pasting my references. Can you, please, help me to solve why I cannot install the Add-on in LibreOffice?
I have the last update version of Zotero. My LibreOffice Version is 7.0.3.1. My Apple : Mojave 10.14.6.
  • edited 27 days ago
    Start by installing a current version of LibreOffice — your version is something like 4 years old.

    Beyond that, see https://www.zotero.org/support/word_processor_plugin_troubleshooting#installation_error
  • Thank you!

    I could not installe the latest version of LO for my Mac does not support the new version but I installed the 7.5.6.1 (X86_64).

    Then I followed the instructions under the link you gave me. I had no JRE in my Java runtime environment for LO. So I downloaded JDK 22 (x64 DMG Installer). But after installing, there is still no JRE in the list and I cannot find where the file is located.

    I tried to add the Zotero plug-in automatically (Zotero / Cite / Word Processor). The problem report is: 855336543. Same error message as before.

    Here is the text: [JavaScript Error: "uncaught exception: unopkg at /Applications/LibreOffice.app/Contents/MacOS/unopkg failed to install"]
    version => 6.0.37, platform => MacIntel, oscpu => Intel Mac OS X 10.14, locale => fr-FR, appName => Zotero, appVersion => 6.0.37, extensions => Zotero Word for Mac Integration (6.0.10.SA.6.0.37, extension), Zotero LibreOffice Integration (6.0.4.SA.6.0.37, extension)

    I tried manually. It says: "Could not create Java implementation loader".

    Do you understand what is going wrong?
  • The problem is the same - you do not have a working JRE for LibreOffice. Make sure you properly quit LibreOffice by right clicking on the LibreOffice application and choosing Quit, then start it again, and check if an option to choose JRE appears in the Options dialog. If it does not, restart your Mac and see if it appears then. If not, you will have to further troubleshoot this with LibreOffice support. As soon as you get Java working in LibreOffice, the Zotero plugin will work too.
  • Thanks!
    I made progress but the problem still exists, despite being a little bit different... After getting help on the LibreOffice forum, I installed a first JRE (21.0.3), then a second one (15.0.3). Both appears in LibreOffice / Preferences / Advanced. I tried to install the Zotero plugin twice selecting either one or the other JRE. Twice the installation succeeded. But still, I cannot find any Zotero tools in my Writer document. It is puzzling me.
  • edited 23 days ago
    I tried to install the Zotero plugin twice selecting either one or the other JRE.
    How exactly are you trying to install it? You should just follow the manual installation instructions.
  • I followed the instruction. I go to Zotero / Preferences / Cite / Word Processor / Install LO plugin.
  • When copying-pasting Applications/Zotero.app/Contents/Resources/integration/libreoffice
    and double-clicking Zotero_OpenOffice_Integration.oxt file
    there is no result. I can see the Zotero icons in LibreOffice but they do not react when clicking on them and disappear when I quit LO and open it anew.
  • Just install the .oxt from the LO Extension Manager, and make sure that it shows up as installed.
  • I did it, as you said: LO Extension Manager / Add, then I selected the correct file Zotero_OpenOffice_Integration.oxt. It did get installed and showed up in the LO Extension manager. Then I re-start LO. But the zotero integration had disappeared from the LO Extension Manager. As if never installed.
  • Try deleting your LO profile directory, as mentioned in Installation Error.
Sign In or Register to comment.