Lagging with Better BibTeX enabled

This discussion was created from comments split from: Zotero Beta GUI with big library lagging during and after sync.
  • I'm having the same problem, though my library is about a fourth of the size of @danielborek's. I am using Better BibTex with an automatically updating bib file. Any change (adding a source, moving a source, deleting a source, adding a subdirectory) causes lagging on the order of 10-15 seconds, though sometimes much longer, with the problem getting worse the longer Zotero is open. Problems seen within the main Zotero app, during which Zotero consumes a ton of CPU. I'm on a M1 mac running Sonoma 14.4.1.

    I've reproduced this with the following Debugging ID performed when attaching a file: D764863472

    I'll also try with BBT disabled.
  • Having a day or so to experiment led me to discover that BBT syncing a bibliography (BibTeX) file was the source of the problem. I've yet to determine a workaround, though I suspect that having the sync occur less often or perhaps not syncing to a OneDrive folder might do the trick.
  • @jhmrrs: You should discuss with the BBT developer on GitHub.
  • I have the same problem, and my .bib file is not on a network folder, using Ubuntu 22.04.
  • For problems with a plugin, you'll need to contact the plugin developer.
  • Yes, will do that!
  • FYI, plugin author is aware of the problem, and working on a performance fix. Meanwhile, the requested workaround is to set auto-export to "on idle":
Sign In or Register to comment.