Zotero Connector can't download PDF files from IEEE Xplore

Zotero Connector no longer saves PDF files.
This only occurs on IEEE Xplore.

Debug ID: 1525852445
URL: https://ieeexplore.ieee.org/document/1663532

message:
"An error occurred saving with IEEE Xplore. Attempting to save using Save as Webpage instead."
https://s3.amazonaws.com/zotero.org/images/forums/u14340489/7rnsqs9h4q6rtnu8suo0.png
  • Same as mine too. It worked well previously. Hope to know how to solve it.
  • Works for me -- Could we, in addition to the error report ID, also get a Debug ID from the connector for a failed save (together with the URL you're saving from, exactly as you see it)?
  • Getting this issue too:
    URL: https://ieeexplore.ieee.org/stamp/stamp.jsp?tp=&arnumber=7503785

    (2)(+0000001): Translate: Translation using IEEE Xplore failed:
    TypeError: url.match is not a function

    TypeError: url.match is not a function
    at Zotero.Translate.Web.resolveURL (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/translate/translation/translate.js:1388:15)
    at Zotero.Utilities.Translate.request (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/translate/utilities_translate.js:306:24)
    at Zotero.Utilities.Translate.requestDocument (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/translate/utilities_translate.js:365:21)
    at Function.requestDocument (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/translate/translation/sandboxManager.js:101:17)
    at doWeb (IEEE%20Xplore:124:22)
    at Zotero.Translate.Web.rest (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/translate/translation/translate.js:1346:49)
    at chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/translate/translation/translate.js:1331:39
    url => https://ieeexplore.ieee.org/stamp/stamp.jsp?tp=&arnumber=7503785
    downloadAssociatedFiles => true
    automaticSnapshots => true

    This is the error from the debug console.
  • Using version 123 works now. Temporary fix. Looks like a regression from the connector in their 124 software
Sign In or Register to comment.